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 Pravljenje 2D elemenata od 
heksagona
U ovoj lekciji odmah ćemo preći na posao i 

napraviti jedan element – postupak počinje 

uvoženjem jednostavnog geometrijskog 

oblika, a završava se vizualizacijom elementa 

u QuickTime formatu. Umetnički utisak ovde 

nije u prvom planu, ali ćete nadovezivanjem 

heksagona u svojevrstan šablon i njegovim 

naknadnim okretanjem, izbleđivanjem i 

zumiranjem u složenoj seriji pokreta dobiti 

veoma zanimljive rezultate. Korišćenjem 

osnovnih svojstava transformacije programa 

After Effects na način koji prevazilazi neka 

najosnovnija znanja, steći ćete sasvim sigurno 

i zavidno iskustvo. 
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Pravljenje 2D elemenata od heksagona
LEKCIJA 1
U ovoj lekciji naučićete kako da:

• napravite datoteke sa After Effects projektima;

• uvezete Adobe Photoshop datoteke;

• interpretirate uvezene alfa kanale (kanal providnosti);

• napravite kompozicije i dodate im slojeve;

• promenite boju pozadine kompozicije;

• radite sa svojstvima transformacije;

• napravite i podesite ključne kadrove prilikom pravljenja animacija;

• umnožavate slojeve;

• promenite In (početne) tačke slojeva;

• zamenite slojeve snimljenog materijala;

• napravite preglede u RAM memoriji;

• preimenujete slojeve;

• unapred rasporedite veći broj slojeva;

• podesite grafikone brzine;

• izvršite vizualizaciju elemenata.

Za koji trenutak počećete rad na dva elementa koji će se koristiti u konačnom projektu.
Oba elementa animacijom formiraju preciznu strukturu pčelinjeg saća od heksagona
koji uleću na ekran iz različitih smerova i u različito vreme. Za ovaj posao biće nam
potrebne samo dve slike.

Nakon opcione pauze, rad na projektu nastavićete dodavanjem novih nivoa složenosti
ovom obliku pčelinjeg saća. Konačno, zamenom ovog grafika dobićete i drugi samosta-
lan element za svoju konačnu animaciju.

Ova lekcija ukupno treba da traje najmanje dva sata, ali je podeljena, tako da možete da
radite u formi od tri školska časa od po 30 do 45 minuta.
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Učionica u knjizi
Početak rada
U prethodnoj celini ove knjige na disku svog računara napravili ste strukturu direktori-
juma i sve izvorne datoteke svih lekcija kopirali u direktorijum AE_CIB job. Ukoliko još
uvek niste napravili strukturu direktorijuma koja je opisana u odeljku „Pripremanje
strukture direktorijuma” na stranici 4, učinite to sada.

Budući da verovatno niste kopirali sve primere filmova i datoteke završenih projekata,
sada je potrebno kopirati sve datoteke koje se koriste u prvoj lekciji.

1 U CD-ROM uređaj svog računara ponovo stavite CD After Effects 6.0 Classroom in a
Book.

2 U programu Windows Explorer (Windows), odnosno Finder (Mac OS), otvorite
direktorijum AE_CIB job koji se nalazi na disku vašeg računara.

3 Zatim u programu Windows Explorer (Windows), odnosno, Finder (Mac OS) dvo-
strukim pritiskom na levi taster miša izaberite ikonu CD-a kako biste mogli da vidite
njegov sadržaj. Otvorite direktorijum AE_CIB na disku, a zatim i direktorijum
Sample_Movies u kome se nalazi direktorijum po imenu Lesson01.

4 Izaberite direktorijum Lesson01 na CD-u i dovucite ga do direktorijuma
Sample_Movies na vašem disku.

5 Na CD-u otvorite direktorijum Finished_Projects i dovucite datoteku Hexa-
gons01_finished.aep do direktorijuma Finished_Projects na disku vašeg računara.

U ovoj lekciji koristićete dve izvorne datoteke:

• Hexagon01.psd i 

• Hexagon02.psd.

Proverite da li se ove datoteke nalaze u poddirektorijumu _psd direktorijuma AE_CIB
job; ako nisu tu, kopirajte ih. Struktura direktorijuma i datoteka je veoma značajna, tako
da vam savetujemo da nikako ne potcenjujete ili odlažete ovaj deo posla.

Zatvorite otvorene prozore i izvadite CD iz CD-ROM-a, a zatim ga stavite na neko
sigurno mesto. Ovakvo kopiranje primera gotovih filmova i završenih projekata ima-
ćete na početku svake lekcije.

Pregledanje probnog filma

U direktorijumu Sample_Movies sada se nalaze završene verzije animacija koje ćete
napraviti u ovoj lekciji. Predlažemo vam da sada pogledate ove filmove kako biste znali
šta treba da dobijete na kraju lekcije. 
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Pravljenje 2D elemenata od heksagona
LEKCIJA 1
1 U Windows Exploreru (Windows) ili Finderu (Mac OS) otvorite direktorijum
Sample_Movies i direktorijum Lesson01 koji se nalazi unutar njega i zatim dvostrukim
pritiskom na levi taster miša izaberite film Hexagons_final kako biste ga otvorili u pro-
gramu QuickTime Player.

2 Pritiskom dugmeta Play pokrenite reprodukciju filma.

3 Zatim dvostrukim pritiskom na levi taster miša izaberite i film HexOutlines_fi-
nal.mov da biste i njega videli u programu QuickTime Player. 

4 Kada završite, zatvorite sve otvorene prozore i QuickTime Player.

Procesor vašeg računara pokušava da reprodukuje filmove brzinom koja je najbliža
njihovoj stvarnoj brzini. Reprodukciju možete da ubrzate smanjivanjem prozora
QuickTime na polovinu njegove prvobitne veličine.

Ukoliko na disku svog računara nemate dovoljno prostora, slobodno obrišite filmove
Hexagons_final.mov i HexOutlines_final.mov iz direktorijuma Sample_Movies.

Pravljenje projekta

Datoteke programa After Effects nazivaju se projekti i prepoznaju se po nastavku .aep
iza naziva datoteke. Vaš prvi zadatak je da napravite novi projekat. U programu After
Effects u jednom trenutku može da bude otvoren samo jedan projekat.

1 Pokrenite After Effects 6.0 ako vam ovaj program već nije otvoren. Ukoliko vam je
trenutno otvoren neki drugi After Effects projekat, snimite ga i zatvorite izborom
komandi File > Save i File > Close.

2 Izaberite File > New > New Project. U naslovnoj liniji prozora Project sada stoji
Untitled Project.aep.

3 Izaberite File > Save As.

4 U okviru za dijalog Save Project As pronađite i otvorite direktorijum _aep koji ste
ranije napravili u direktorijumu AE_CIB job.

5 U polju File Name upišite Hexagons01_work.aep.

Napomena: Naziv projekta u kome imate i dodatak _work pomoći će vam da ovu dato-
teku razlikujete od datoteke Hexagons01_finished.aep (primer gotovog projekta) koju ste
kopirali sa CD-a u direktorijum Finished_Projects.

6 Pritisnite dugme Save.

Nakon zatvaranja ovog okvira za dijalog, u naslovnoj liniji prozora Project moći ćete da
vidite novi naziv projekta.
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Učionica u knjizi
Proverite da li su palete Info i Time Controls otvorene. Ukoliko niste sigurni, potražite
meni After Effects Window i proverite da li su opcije Info i Time Controls izabrane
(znak za potvrdu). Ako nisu, izaberite ih sada kako biste ih otvorili.

Pravljenje prve kompozicije heksagona
U ovom odeljku napravićete složenu, animiranu kompoziciju korišćenjem svojstava
transformacije. Kopiranjem jednostavnih slika dobićete kompoziciju koja koristi vrlo
malo prostora na disku i ostaje fleksibilna u radu.

Uvoženje materijala za prvu kompoziciju

Ono što sada sledi jeste uvoženje izvorne datoteke. Slika koju ćete koristiti dobijena je u
Photoshopu i u njoj se za definisanje heksagonalnog oblika koristi alfa kanal. Alfa
kanali su providne oblasti koje mogu da se definišu u aplikaciji u kojoj se datoteka pravi.
Prilikom uvoženja datoteke u kojoj postoji neobeleženi alfa kanal, neophodno je da se
naznači na koji način će program After Effects taj alfa kanal interpretirati.

1 Izaberite File > Import > File.

2 U okviru za dijalog Import File otvorite direktorijum _psd koji se nalazi unutar
direktorijuma AE_CIB job i izaberite datoteku Hexagon01.psd.

3 Pritisnite dugme Open (Windows), odnosno, Import (Mac OS).

4 U okviru za dijalog Interpret Footage izaberite opciju Straight – Unmatted i zatim
pritisnite OK.

Nakon toga, datoteka Hexagon01.psd pojavljuje se u listi prozora Project. Ukoliko ime
ove datoteke već nije izabrano, izaberite ga kako biste mogli da vidite njen minijaturni
prikaz i dobijete neke informacije o njoj na vrhu prozora Project. U ove informacije spa-
daju veličina slike (400 x 400 pixels), broj boja (Millions of Colors+) i interpretacija alfa
kanala (Straight).
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LEKCIJA 1
Interpretiranje alfa kanala

Alfa kanali imaju ključnu ulogu u dobijanju zanimljive pokretne grafike profesionalnog kvaliteta u
programu After Effects. Iako sve lekcije u ovoj knjizi možete da savladate i bez detaljnog razumevanja
alfa kanala, kada budete počeli da pravite sopstvene projekte, u ovoj temi za vas ne bi smelo da bude
nepoznanica. Da li ćete se sada detaljnije pozabaviti alfa kanalima, ili ćete se kasnije vratiti na ovu
temu, stvar je vašeg izbora.

Prilikom uvoženja datoteke sa neobeleženim alfa kanalom u projekat, pojavljuje se poruka u kojoj se
od vas traži da precizirate način na koji će se dati alfa kanal interpretirati. Od metoda interpretacije
alfa kanala zavisi izgled sloja u kompoziciji i konačnom mediju. U ovom smislu vaš izbor zavisi od
toga na koji je način alfa kanal prvobitno dobijen, zato što za svaku vrstu alfa kanala postoji odgova-
rajući način interpretacije.

Tri osnovne opcije koje se pojavljuju u okviru za dijalog Interpret Footage su:

• Ignore

• Straight – Unmatted

• Premultiplied – Matted with Color

Straight – Unmatted: U slučaju datoteke Hexagon01.psd koja se koristi u lekciji 1, providnost je
definisana samo u alfa kanalu. RGB kanali se ponašaju kao jedinstvena bela „popuna” za alfa ili
matte (postavljeni) kanal. Ovo je veoma slično načinu na koji se list razmotanog testa ponaša ispod
modle za kolače. Ova vrsta alfa kanala naziva se i verni (pravi) alfa (engl. straight alpha). Prema
tome, kada se ova vrsta alfa kanala uvozi u After Effects, treba je interpretirati opcijom Straight –
Unmatted.

Ignore: Ovaj metod interpretacije ne uvažava informacije o alfa kanalu (providnosti) koje su
definisane u originalnoj datoteci i daje sloju potpunu (100% neprovidnu) pozadinu. U lekciji 8 bićete
u prilici da koristite opciju Ignore.

Premultiplied – Matted With Color: Ovim izborom uklanja se originalna boja pozadine sa
poluprovidnih ivica objekta. Ovim se sprečava pojavljivanje oreola oko slike.

Napomena: Neke datoteke mogu pravilno da se interpretiraju korišćenjem i opcije Premultiplied i
opcije Straight.

Ukoliko ne znate na koji način je napravljen alfa kanal datoteke koju koristite, pritisnite dugme Guess.
Nakon toga After Effects će pokušati da ustanovi vrstu alfa kanala koja se koristi u datoteci, a zatim
i da primeni odgovarajući metod interpretacije. U slučaju da u tome ne uspe, After Effects će se oglasiti
zvučnim upozorenjem. 

U okviru za dijalog Interpret Footage takođe postoji i opcija Invert Alpha. Izborom njenog polja za
potvrdu dobija se obrnuti izgled alfa kanala.

Dodatne informacije o alfa kanalima možete da potražite u onlajn pomoći programa After Effects 6.0,
kao i u pratećoj dokumentaciji programa Adobe Photoshop, Adobe Illustrator, Adobe Premiere® ili
drugih aplikacija koje mogu da prave slike sa alfa kanalima. Na veb lokaciji kompanije Adobe pronaći
ćete i neke tehničke članke o alfa kanalima.
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Organizovanje projekta

Organizovanje datoteka jednog After Effects projekta je isto onoliko važno koliko i
organizovanje datoteka i poslova na disku vašeg računara. Baš kao što ste na početku
ovog posla na svom disku napravili direktorijume koji će vam pomoći u organizaciji
rada (odeljak „Pripremanje strukture direktorijuma”, strana 4), sada ćete napraviti
direktorijume koji će vam pomoći u organizaciji ovog After Effects projekta.

1 Izaberite File > New > New Folder, ili pritisnite ikonu omotnice ( ) koja se nalazi u
donjem delu prozora Project. Nakon toga, u prozoru Project pojavljuje se direktorijum
bez imena.

2 Upišite psd files i pritisnite taster Enter (Windows), odnosno, Return (Mac OS) kako
biste ovom direktorijumu dodelili ime.

3 Dovucite datoteku Hexagon01.psd do direktorijuma psd files.

4 Pomoću strelice (trouglić) proširite direktorijum psd files kako biste mogli da vidite
datoteku Hexagon01.psd koju ste smestili u njega.

U ovoj lekciji uvešćete samo .psd datoteke, tako da vam neće biti potrebni drugi direk-
torijumi. Kasnije, kada budete radili mnogo složenije projekte, napravićete direktori-
jum za svaki tip datoteke koji se u njemu pojavljuje.

Pravljenje prve kompozicije

Građenje vaše animacije započeće pravljenjem nove kompozicije. Kompozicije predsta-
vljaju osnovne celine jednog After Effects projekta u koje se smeštaju slike, filmovi,
zvuk, pa čak i druge kompozicije kojima želite da manipulišete.
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LEKCIJA 1
1 Izaberite Composition > New Composition.

2 U okviru za dijalog Composition Settings u polje Composition Name upišite
Hexagon Final Comp.

Napomena: Reč finalno govori da je reč o kompoziciji za vizualizaciju na kraju lekcije.
Ovom rečju ona se razlikuje od ostalih kompozicija koje ćete u međuvremenu napraviti u
ovoj lekciji.

3 Korišćenjem priručnog menija Preset izaberite opciju NTSC D1 Square Pix, 720 x
540.

4 Obavezno proverite da li su izabrani sledeći parametri:

• Width: 720

• Height: 540

• Lock Aspect Ratio: neizabrano (bez znaka za potvrdu)

• Pixel Aspect Ratio: Square Pixels

• Frame Rate: 29.97

• Resolution: Full (Možete da izaberete i nižu rezoluciju; koristite rezoluciju Half ili
nižu ukoliko vaš sistem ne obiluje RAM memorijom ili ima spor procesor.)

• Start Timecode: 0;00;00;00

Konačni (izlazni) formati

U ovoj fazi projekta veoma je važno razmisliti i o formatu u kome će vaš projekat da završi (film, Web
ili televizija), zato što od toga zavisi veličina u kojoj ćete praviti svoje elemente. Ovi parametri se
definišu na nivou kompozicije.

Iz scenarija posla koji smo pomenuli u uvodnom delu ove knjige znate da je ova animacija namenjena
pre svega za NTSC emitovanja. To znači da vizualizacija vaše završene animacije treba da bude
izvršena u rezoluciji D1 (720 x 486). Prema tome, potrebno je da elemente u kompozicijama pravite
tako da budu dovoljno veliki za konačni format animacije.

Za rezoluciju D1 karakteristično je to da pikseli nemaju kvadratni oblik. S obzirom na to da vaš
monitor sliku prikazuje kvadratnim pikselima, lekcije ćete raditi u kvadratnoj razmeri piksela, a zatim
ćete, pre konačne vizualizacije, finalnu kompoziciju prebaciti u format 720 x 486 D1 NTSC.
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Opcijom Preference možete da odredite veličinu i izgled kompozicije u zavisnosti od
njene rezolucije. U tom smislu, ukoliko smanjite rezoluciju u prozoru Composition,
zadržaćete jasnoću slike, ali ćete smanjiti njen prikaz. Ovo je naročito korisno ukoliko
imate mali monitor ili radite sa kompozicijom koja prelazi granice čak i nekog većeg moni-
tora. Za aktiviranje ove opcije pritisnite Edit > Preferences > Display (Windows), ili After
Effects > Preferences > Display (Mac OS) i zatim izaberite opciju Auto-zoom When Reso-
lution Changes. 

5 U polje Duration upišite 400 za četiri sekunde.

6 Kada sve opcije budu podešene, pritisnite OK.

Naziv (stavka) Hexagon Final Comp sada se pojavljuje u prozoru Project, kao i u
naslovnim linijama dva nova prozora – Composition i Timeline. Ukoliko je neophodno,
promenite veličinu ovih prozora kako bi svi mogli da stanu na vaš ekran. Prozor Com-
position, u kome obično možete da vidite kako vaša kompozicija izgleda, sada je prazan
(sasvim crn, ili u onoj boji koju ste izabrali za svoju pozadinu), zato što u svoju novu
kompoziciju još uvek niste dodali nikakvu sliku.

Prozor Timeline je takođe prazan, s tim što u njemu možete da vidite razne kontrole
koje ćete koristiti za manipulisanje sastavnim delovima kompozicije. Skrećemo vam
pažnju na to da je na desnoj strani prozora Timeline navedeno trajanje koje ste naznačili
– četiri sekunde.



20
Pravljenje 2D elemenata od heksagona
LEKCIJA 1
Prozor Timeline možete da učinite podesnijim za rad u ovoj lekciji time što ćete zatvo-
riti panel Parent. Pritiskom na desni taster miša (Windows), ili taster Control i levi taster
miša (Mac OS), izaberite reč Parent u naslovu panela kako biste otvorili kontekstni meni,
a zatim iz njega izaberite opciju Hide This.

Smeštanje materijala u kompoziciju

Materijal koji se dodaje u kompoziciju potrebno je pozicionirati i u prostoru i u vre-
menu. Iako ovi parametri mogu da se doteraju i kasnije, preporučuje se da ono što sta-
vljate u kompoziciju odmah postavite na pravo mesto.

Tačka In (početna tačka) jeste tačka u vremenu u kojoj se ubačeni materijal prvi put
pojavljuje ili u kojoj u kompoziciji započinje njegova reprodukcija. Kada sloj ubacite u
kompoziciju, njegova tačka In se automatski postavlja na poziciju markera aktuelnog
vremena ( ). U ovom slučaju, želimo da slika počne da se pojavljuje u prvom kadru ani-
macije (00;00;00;00), tako da u podvučenom prikazu aktuelnog vremena, u gornjem
levom uglu prozora Timeline, treba da stoji upravo ova vrednost. Postoji nekoliko
načina za promenu pozicije markera aktuelnog vremena.

1 Ukoliko marker aktuelnog vremena nije na položaju 0:00, postupite na jedan od sle-
dećih načina:

• Mišem izaberite prikaz aktuelnog vremena kako biste otvorili okvir za dijalog Go To
Time, upišite vrednost 0 (broj nula) i pritisnite dugme OK.

• Povucite marker aktuelnog vremena sasvim ulevo.

• Pritisnite taster Home.

2 U prozoru Project izaberite datoteku Hexagon01.psd i dovucite je do prozora Com-
position.

3 Nastavite sa povlačenjem sve dok se grafički okvir (kontura koja ukazuje na dimen-
zije slike) ne postavi sasvim malo iznad centra na desnoj strani kompozicije.
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Kada pustite taster miša, heksagon se pojavljuje u prozoru Composition. Osim toga,
datoteka će se pojaviti i u prozoru Timeline kao Layer 1 u kome je navedena pod ime-
nom Hexagon01.psd – što je njen izvorni naziv.

Napomena: Ukoliko je pozadina u prozoru Composition bele boje, heksagon nećete moći
da vidite (on je takođe bele boje). Ovaj problem možete da rešite tako što ćete izborom
komandi Composition > Background Color otvoriti okvir za dijalog Background Color.
Zatim izborom palete boja otvorite okvir za izbor boja u kome treba da izaberete crnu
pozadinu. Nakon toga, pritiskom dugmeta OK, zatvorite oba okvira za dijalog.

Svojstva transformacije

Svojstva transformacije predstavljaju srž programa After Effects. Kada ovladate načinima njihovog
korišćenja, kao i dodavanjem ključnih kadrova ovim parametrima, mogućnosti postaju praktično
neograničene. U ovoj knjizi praktično svako podešavanje nekog sloja koje ćete načiniti u programu
After Effects zasnivaće se na principima koji se odnose na rad sa svojstvima transformacije.

Svojstvima transformacije slojeva možete da pristupite na dva načina. Možete da pritisnete strelicu
koja se nalazi levo od imena sloja i tako otkrijete kategoriju Transform. Zatim, pritiskom na strelicu
koja se nalazi pored natpisa Transform možete da otkrijete pet svojstava za transformaciju datog sloja
– Anchor Point, Position, Scale, Rotation i Opacity. Promenom vrednosti ovih parametara, možete da
izmenite izgled sloja.

Sa druge strane, česte su i situacije u kojima želite da pristupite samo nekom od ovih svojstava.
Otvaranje svih svojstava transformacije odjednom može da vas omete i uspori zato što je njihova lista
nekada veoma duga, tako da pronalaženje željenog svojstva nije najjednostavnije. U ovakvim situa-
cijama koriste se prečice na tastaturi koje omogućavaju otvaranje samo željenih svojstava. Zahva-
ljujući njima prozor Timeline neće postati prenatrpan i snalaženje u njemu je jednostavnije. Evo koje
su to prečice:

A = Anchor Point (referentna tačka)

P = Position (pozicija)

S = Scale (veličina)

R = Rotation (rotacija)

T = Opacity (neprovidnost)

Prilikom upotrebe druge prečice, dato svojstvo zamenjuje ono koje ste prethodno otvorili, čime se
prozor Timeline rasterećuje. Ukoliko ipak budete želeli da istovremeno otvorite nekoliko svojstava
transformacije, prilikom korišćenja ovih prečica držite pritisnut i taster Shift.

Nema razloga da se sada opterećujete pamćenjem svih ovih detalja zato što ćemo vas u postupcima
koji su opisani u ovoj knjizi podsetiti i na svojstva i na prečice do njih. Dodatne informacije na ovu
temu možete da potražite u After Effectsovoj onlajn pomoći „Viewing layer properties in the Timeline
window” („Pregledanje svojstava slojeva u prozoru Timeline”).
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Transformisanje slike
U programu After Effects termin transformisanje rezervisan je za neka konkretna svoj-
stva slojeva kao što su njihov položaj, razmera (veličina), rotacija, neprovidnost i
položaj referentne tačke. Kada završite rad na elementu heksagona, svako od ovih svoj-
stava za transformisanje primenićete najmanje jednom (nekad i više puta) i to u različi-
tim situacijama i kombinacijama.

Pomeranje slike na konkretan položaj

Imajući u vidu to da ćete korišćenjem slike Hexagon01.psd napraviti veoma precizan
šablon, vaš sledeći korak biće doterivanje položaja ove slike u okviru kompozicije.

1 Ukoliko sloj nije izabran, u prozoru Composition izaberite sliku ili u prozoru Time-
line ime sloja.

Da biste izbegli neophodnost skrolovanja slike u prozoru Composition, koristite pri-
ručni meni za uveličavanje koji se nalazi u donjem levom uglu prozora ili pritisnite taster
zarez (,) kako biste se udaljili od slike. Ako želite da povećate brzinu obrade i iscrtavanja
u toku rada, u ovom priručnom meniju možete da smanjite i vrednost rezolucije prozora
Composition sa Full na neku nižu vrednost (recimo, Half ili Third). Skrećemo vam pažnju
na to da ovim parametrima utičete samo na svoj pogled u toku rada, a ne i na stvarnu
veličinu i kvalitet finalne animacije.

Opcije Magnification (uveličavanje, levo) i Resolution (rezolucija, desno)
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2 Pritisnite taster P na tastaturi računara. Nakon toga, svojstvo Position se pojavljuje
ispod sloja u prozoru Timeline.

3 Pomerite sloj do (ili blizu) X i Y koordinata 468, 242 na neki od sledećih načina:

• Povucite sloj kroz prozor Composition ravnajući se prema koordinatnom prikazu
palete Info ili svojstvu Position u prozoru Timeline.

Ukoliko budete imali problema sa postavljanjem sloja tačno na koordinate 468 i 242,
upotrebite tastere sa strelicama koji omogućavaju veću preciznost pomeranja.

• Povucite koordinate podvučenog svojstva Position u prozoru Timeline. Povlačenjem
udesno vrednost se povećava, a povlačenjem ulevo ona se smanjuje.
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• U prozoru Timeline izaberite koordinate položaja i jednostavno upišite vrednosti 468
za X osu i 242 za Y.

Napomena: Ove koordinate X i Y označavaju položaj referentne tačke sloja u okviru pro-
zora Composition. Prema podrazumevanim parametrima After Effects referentnu tačku
postavlja u sredinu sloja.

Referentna Tačka i ručke za izbor slojeva

Podešavanje veličine slike

U svakodnevnom životu veoma često ste u situaciji da morate da radite sa slikama čija
veličina nije idealna za kompoziciju. U vezi sa tim, u ovom zadatku ćete smanjiti veli-
činu slike heksagona kako bi se finalna linija heksagona koju napravite uklopila u kadar
kompozicije onako kako vi to želite.
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1 Ili u prozoru Composition ili u prozoru Timeline izaberite sloj Hexagon01.psd.

2 Pritisnite taster S na tastaturi. Nakon toga se u prozoru Timeline, ispod sloja, poja-
vljuje svojstvo Scale i zamenjuje svojstvo Position.

3 Promenite vrednost svojstva Scale u 57%, ili povlačenjem, ili direktnim upisivanjem
vrednosti, a zatim pritisnite taster Enter (Windows), odnosno, Return (Mac OS). U pro-
zoru Timeline uključena je, prema podrazumevanim parametrima, opcija Constrain
Proportions ( ), tako da je svejedno da li ćete ovu vrednost upisati u polje za horizon-
talnu ili u polje za vertikalnu dimenziju – vrednost se automatski prenosi u drugo polje.

Nakon ovoga, u prozoru Composition pojavljuje se smanjeni heksagon.

Podešavanje ključnih kadrova za rotiranje slike

Sledeće što treba da učinite je da heksagon rotacijom dođe na svoje mesto. U ovom
zadatku animiraćete heksagon i to tako da se u prvih 15 kadrova kompozicije od četiri
sekunde rotira za 180 stepeni.

Da biste precizirali način na koji će se stvari menjati tokom vremena, koristićete ključne
kadrove. Ključni kadar (engl. keyframe) predstavlja referentnu tačku koja vrednost svoj-
stva sloja povezuje sa tačkom u vremenu. Da biste postigli rotaciju slike, jednom ključ-
nom kadru treba da date početnu vrednost svojstva Rotation, a drugom njegovu krajnju
vrednost. Program After Effects zatim sam izračunava vrednosti rotacije između ova
dva ključna kadra, kako ne biste morali da pravite ključni kadar za svaki pojedinačni
kadar između ove dve referentne tačke.

1 Ukoliko je to potrebno, pomerite marker aktuelnog vremena na poziciju 0:00 (nje-
govim povlačenjem, pritiskom tastera Home ili otvaranjem okvira za dijalog Go To
Time i upisivanjem vrednosti 0).

2 U prozoru Timeline izaberite sloj Hexagon01.psd.

3 Pritiskom tastera R otvorite svojstvo Rotation ovog sloja. Pored ovog svojstva ugle-
daćete dva podvučena broja – prvim se navodi broj rotacija, dok drugi pokazuje broj
dodatnih stepeni.

4 Vrednost prvog broja (rotacija) neka ostane nula, a drugom broju, povlačenjem ili
upisivanjem dodelite vrednost -180°, vodeći računa o tome da broj obavezno bude
negativan.
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5 Izaberite ikonu štoperice koja se nalazi levo od svojstva Rotation. Pored nje sada
postoje ručke ( ), a na vremenskoj liniji na poziciji markera aktuelnog vremena (0:00)
pojavljuje se mala ikona oblika dijamanta ( ) koja predstavlja ključni kadar.

Štoperica rotacije (levo) i ključni kadar (desno)

6 Povucite marker aktuelnog vremena na poziciju 0:15 ili izaberite prikaz aktuelnog
vremena i u okvir za dijalog Go To Time upišite vrednost 15.

7 Povlačenjem ili upisivanjem promenite vrednost druge rotacije u 0° (nula), nakon
čega se na poziciji markera aktuelnog vremena automatski pojavljuje novi ključni
kadar.

Važno: Kada podešavate ključne kadrove za bilo koje svojstvo u programu After Effects,
vodite računa o tome da ikonu štoperice izaberete samo jednom. Ručke sata unutar štope-
rice govore da svojstvo može da se menja tokom vremena, tako da After Effects, prilikom
pomeranja markera aktuelnog vremena, automatski dodaje ključne kadrove i menja vred-
nost datog svojstva. Kada štopericu pritisnete drugi put, to je znak da se svojstvo ne menja
kroz kompoziciju, tako da program uklanja sve njegove ključne kadrove (nestaju ručke sa
ikone). Ukoliko vam se dogodi da ovu ikonu slučajno pritisnete dva puta, izaberite
komandu Edit > Undo, ili na tastaturi pritisnite tastere Ctrl + Z (Windows), odnosno,
Command + Z (Mac OS), kako biste poništili poslednju akciju i sebe poštedeli ponovnog
pravljenja izbrisanih ključnih kadrova. Kada budete želeli da izbrišete neki konkretan
ključni kadar, jednostavno ga izaberite i pritisnite taster Delete.
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Pregledanje vaše prve animacije

Kompoziciju koju ste upravo napravili sada možete da pogledate kako biste videli rezul-
tate postavljanja ključnih kadrova.

1 Pritisnite taster Home kako biste marker aktuelnog vremena pomerili na poziciju
0:00.

2 Pritiskom razmaknice ili dugmeta Play ( ) koje se nalazi u paleti Time Controls
pokrenite reprodukciju.

Napomena: Tokom reprodukcije pregleda, marker aktuelnog vremena se pomera duž vre-
menske linije, a iznad nje se pojavljuje zelena linija. Nakon što ovaj marker pređe poziciju
0:15, heksagon se više ne pomera sve dok se pregled ponovo ne vrati do početne pozicije.

3 Kada završite pregledanje, ponovo pritisnite taster Play kako biste pauzirali pregled
ili ponovo pritisnite razmaknicu da biste ga zaustavili. 

Za sada smo završili sa svojstvom Rotation i zato pritisnite taster akcenat gravis (`) kako
biste ga ponovo sakrili. Isti efekat možete da postignete i pritiskom na taster R.

Mnoge kontrole programa After Effects, uključujući tu i dugmad palete Time Controls,
imaju savete o alatkama – male prozore koji se pojavljuju, nakon nekoliko trenutaka sta-
janja kursora na datom dugmetu, alatke ili opcije. Ukoliko ne možete da ih vidite, izabe-
rite Edit > Preferences > General (Windows), odnosno, After Effects > Preferences >
General (Mac OS) i proverite da li je opcija Show Tool Tips izabrana.

Pravljenje animiranog šablona od jednostavne slike
Za pravljenje elementa heksagona moglo bi da vam bude potrebno veoma mnogo slo-
jeva heksagona. Umesto da na svakom dodatnom heksagonu ponavljate sve promene
koje ste načinili sa prvim slojem, bolje je da ovaj prvi sloj kopirate onoliko puta koliko
je potrebno. Na taj način se, osim samog sloja, kopiraju i sve promene koje ste na njemu
načinili kao i ključni kadrovi postavljeni za svojstva Scale, Position i Rotation, što omo-
gućava veliku uštedu vremena. Vaš prvi zadatak biće pravljenje duplikata.

1 Dovucite marker aktuelnog vremena do pozicije 0:00 ili pritisnite taster Home.

2 U prozoru Timeline ili u prozoru Composition izaberite sloj Hexagon01.psd, a zatim
pritisnite Edit > Duplicate. Nakon toga, novi sloj se pojavljuje u prozoru Timeline iznad
originalnog sloja.

3 Kopirajte originalni sloj još osam puta komandom Edit > Duplicate ili pritiskom
tastera Ctrl + D (Windows), odnosno, Command + D (Mac OS).
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Obratite pažnju na to kako se kopiranje prvog sloja odražava u prozorima:

• Kao što možete da vidite, izgled prozora Composition se ne menja. To je zato što su
slike (njih deset) poređane tačno jedna iznad druge na identičnim koordinatama pozi-
cija.

• U prozoru Timeline svih deset slojeva ima ime Hexagon01.psd zato što svi slojevi kori-
ste istu izvornu datoteku. U skladu sa svojim položajem u gomili slojeva (odozgo nadole
ili spreda unatrag), svaki sloj se identifikuje brojem levo od imena.

• Parametri svojstava Rotation, Scale i Position svih slojeva identični su sa odgovaraju-
ćim vrednostima prvog sloja. Ovo možete i da proverite tako što ćete izabrati jedan sloj
ili više njih, i zatim pritisnuti taster R, S ili P.

Raspoređivanje slojeva u šablon

Sledeće što treba da učinite je da deset heksagona rasporedite tako da od njih dobijete
formaciju oblika pčelinjeg saća. Slojeve ćete da rasporedite onako kako je prikazano na
sledećoj ilustraciji.

Slojevi od 1 do 10 na svojim konačnim položajima

8 57 4 2

9 6 3

110
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Želimo da istaknemo da nemate obavezu da koristite one koordinate koje smo naveli u
sledećem postupku. Međutim, ukoliko ih budete koristili, koordinate aktuelnog sloja
obavezno treba da budu 468 i 242. U suprotnom, heksagone možete da rasporedite i
odoka tako da formiraju šablon u kome su jedan od drugog podjednako udaljeni.

1 U prozoru Timeline izaberite sloj koji se nalazi na vrhu (Layer 1). Obratite pažnju na
ručke sloja (mali kvadrati u uglovima grafičkog okvira sloja) koje se pojavljuju u pro-
zoru Composition. Pritiskom na taster P otvorite svojstva Position datog sloja. 

Napomena: Ukoliko ne možete da vidite ručke sloja, izaberite dugme sa strelicom koja
pokazuje udesno koje se nalazi u gornjem desnom uglu prozora Composition, i zatim iz
menija prozora izaberite komandu View Options. U okviru za dijalog View Options
potvrdite polje Handles (ukoliko nema znaka potvrde) i zatim pritisnite dugme OK.
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2 Odvucite sloj Layer 1 desno od kompozicije tako da jedan njegov deo bude vidljiv, a
drugi izvan okvira kompozicije.

3 U prozoru Timeline ispitajte koordinate svojstva Position sloja Layer 1.

4 Ukoliko želite da koristite koordinate koje su upotrebljene u primeru, sliku postavite
na poziciju čije su koordinate 723, 242 povlačenjem u prozoru Composition. To možete
da učinite i povlačenjem vrednosti koordinata, ili direktnim upisivanjem ovih vrednosti
u prozoru Timeline. Da biste precizno pomerali sloj, isprobajte i sledeće tehnike:

• Nakon što započnete povlačenje sloja, pritisnite taster Shift da biste pomeranje ogra-
ničili samo na horizontalno ili vertikalno kretanje.

• Pritiskom na taster sa strelicama, sliku možete da pomerate u malim pomacima.

• Prilikom direktnog upisivanja, upotrebom tastera Tab možete da skočite sa jedne
koordinate na sledeću, kao i sa poslednje koordinatne vrednosti jednog sloja na prvu
koordinatnu vrednost sledećeg sloja.
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5 Pređite redom na sledeće slojeve i postavite ih na pozicije koje su prikazane na ilu-
straciji sa početka ovog postupka. Ukoliko želite da koristite koordinate koje su
korišćene u našem primeru, pomoći će vam sledeći spisak:

Layer 1 723,242

Layer 2 595,169

Layer 3 595,316

Layer 4 Ostavite na prvobitnoj poziciji (468, 242)

Layer 5 341,169

Layer 6 341,316

Layer 7 214,242

Layer 8 87,169

Layer 9 87,316

Layer 10 -40,242

6 Izaberite File > Save.

Započinjanje nove animacije pravljenjem ključnih kadrova

Raspoređivanjem deset heksagona, dobili ste formaciju pčelinjeg saća. Sada ćete za
svaki sloj da postavite ključni kadar pozicije.

1 Povlačenjem ili direktnim upisivanjem, pomerite marker aktuelnog vremena na
poziciju 0:15.

2 Komandom Edit > Select All, ili pritiskom na tastere Ctrl + A (Windows), odnosno,
Command + A (Mac OS), izaberite sve slojeve. Zatim, ukoliko svojstvo Position već nije
otvoreno, pritisnite taster P kako biste ga otvorili za sve slojeve.
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3 Pritisnite tastere Alt + P (Windows), ili Option + P (Mac OS) kako biste odjednom
postavili ključni kadar Position svih slojeva. Skrećemo vam pažnju na to da ikone štope-
rice (levo od reči Position) sada imaju ručke i da su se na vremenskoj liniji svakog sloja,
na poziciji 0:15, pojavile ikone ključnih kadrova koje imaju oblik dijamanta.

4 Komandom Edit > Deselect All ili pritiskom tastera Ctrl + Shift + A, odnosno, Com-
mand + Shift + A (Mac OS) poništite izbor svih slojeva. Svojstva Position neka ostanu
otvorena.

Ovakav raspored heksagona predstavlja konačnu poziciju animiranog šablona heksa-
gona. 
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Dalje animiranje heksagona

Sada ste spremni za definišete početni položaj svakog heksagona. Cilj vam je da svaki
od njih, okrećući se, uleti u kompoziciju i zauzme svoje mesto u šablonu pčelinjeg saća.
Da biste to postigli, svakom sloju ćete dodeliti početnu poziciju koja se nalazi izvan
okvira kompozicije. S obzirom na to da je ovde korisno da vidite veći deo površine oko
okvira sa kompozicijom (sive oblasti koja okružuje kompoziciju), prvi korak će biti
udaljavanje od kompozicije. Skrećemo vam pažnju na to da se ovim menja samo vaš
pogled; veličina objekta u animaciji ostaje ista.

Slojevi od 1 do 10 na svojim početnim pozicijama

Ukoliko ne želite da trošite vreme na postavljanje heksagona na one položaje u koje smo
ih mi postavili, jednostavno ih postavite otprilike onako kako su raspoređeni na pret-
hodnoj ilustraciji. Ove početne pozicije heksagona su mnogo manje značajne od njiho-
vih konačnih pozicija u šablonu pčelinjeg saća koji zahteva veću preciznost.

1 Iz priručnog menija za uveličavanje koji se nalazi u donjem levom uglu prozora
Composition, izaberite vrednost 50% (ili manju). Isti učinak postiže se i pritiskom na
taster sa zarezom (,) koji omogućava postupno udaljavanje.

2 Pomerite marker aktuelnog vremena na poziciju 0:00.
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3 Koristeći onu tehniku koja vam najviše odgovara, postavite heksagone na položaje
prikazane na prethodnoj slici. Ukoliko želite da koristite koordinate koje su korišćene u
primeru, pomoći će vam sledeći spisak:

Layer 1 723, -51

Layer 2 -192, 169

Layer 3 595, 607

Layer 4 468, -49

Layer 5 341, 594

Layer 6 -125, 316

Layer 7 825, 242

Layer 8 87, -94

Layer 9 87, 595

Layer 10 -140, 242

Posle definisanja novih pozicija, svaki sloj (na poziciji 0:00) dobija ključni kadar.

4 Pritiskajući razmaknicu pregledajte svoju animaciju, ili pritiskom na taster 0 (nula)
na numeričkoj tastaturi napravite RAM pregled. Kada završite, ponovo pritisnite raz-
maknicu.

5 Sa aktivnim prozorom Timeline pritisnite tastere Ctrl + A (Windows), odnosno
Command + A (Mac OS) kako biste izabrali sve slojeve, a zatim pritiskom tastera akce-
nat gravis sakrijte svojstva Position. Komandom Edit > Deselect All poništite izbor svih
slojeva.

6 Komandom File > Save snimite ovo što ste do sada uradili.

Kada napravite RAM pregled, povlačenjem markera aktuelnog vremena možete da se
krećete kroz kompoziciju. Ukoliko isto to učinite pre nego što napravite RAM pregled, pro-
gram After Effects će ažurirati prozor Composition onoliko brzo koliko bude mogao (to
zavisi od brzine procesora, količine RAM memorije i brzine grafičke kartice vašeg raču-
nara). Dodatne informacije o ovoj temi možete da potražite u odeljku „Dodeljivanje RAM
memorije programu After Effects” na strani 2. Osim toga, pročitajte i odeljke „Saving a
RAM preview as a rendered movie” i „Tehniques for working efficiently” onlajn pomoći
programa After Effects.
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RAM pregledi
Šta je RAM pregled? Kada pritiskom na razmakniu ili dugme Play iz palete Time Controls pokrenete
pregled animacije, brzina reprodukcije ne odgovara realnom vremenu. Brzina kojom se kompozicija u
tom slučaju reprodukuje zavisi od brzine procesora vašeg računara i približava se stvarnoj brzini koliko
god je to moguće. Pravljenje RAM pregleda vam omogućava da, u zavisnosti od raspoložive RAM
memorije i brzine grafičke kartice vašeg računara, kompoziciju pregledate i u realnom vremenu.

Prilikom pravljenja RAM pregleda program After Effects najpre u RAM memoriju učitava kadrove, a
zatim pokušava da ih reprodukuje. Prvi prolazak kroz pregled uvek deluje znatno sporije. Kako After
Effects pravi ovaj pregled, zelena linija se pomera duž vremenske ose, ukazujući na to dokle je program
u ovom poslu stigao. Nakon učitavanja pregleda u RAM, animacija može da se reprodukuje u realnom
vremenu ili maksimalnom brzinom koju vaš sistem može da postigne.

Ukupan broj kadrova RAM pregleda zavisi od toga koliko je informacija moguće učitati u RAM
memoriju vašeg sistema. Ukoliko veličina kompozicije prelazi iznos RAM memorije vašeg računara,
After Effects pregled pravi od onog broja kadrova koji je moguće učitati i zatim njih reprodukuje u
realnom vremenu. U slučaju da je kompozicija veoma velika i složena, moći ćete da vidite samo jedan
kratak segment vremenske linije.

Trajanje pravljenja RAM pregleda zavisi od brzine procesora računara, dok brzina u kadrovima zavisi
od raspoložive RAM memorije i brzine grafičke kartice.

RAM pregled može da se napravi na sledeće načine:

• Izborom komande Composition > Preview > RAM Preview.
• Pritiskom dugmeta RAM Preview koje se nalazi u paleti Time Controls.
• Pritiskom na taster 0 (nula) na numeričkoj tastaturi.

Optimizovanje RAM pregleda Kod jednostavnih kompozicija pravljenje RAM pregleda je brzo
skoro kao i standardni pregled. Međutim, kod veoma složenih kompozicija proces generisanja RAM
pregleda može da bude veoma dugotrajan, a broj kadrova ograničen iznosom RAM memorije koja je
dodeljena programu. Na sledeće načine možete da izvučete maksimum iz RAM pregleda:

• Zatvaranjem ostalih aplikacija (Windows) ili povećanjem iznosa memorije koja je dodeljena 
programu (Mac OS).
• Spuštanjem vrednosti parametra Resolution (ili u prozoru Composition ili u paleti Time Controls) 
na vrednosti Half ili Third. Ovo smanjenje rezolucije odnosi se samo na pregled; nakon vizualizacije 
kompozicije, slika ostaje sa punim uklanjanjem nazubljenosti.
• Smanjivanjem nivoa uvećanja u prozoru Composition na vrednost 50% ili nižu.
• Promenom vrednosti opcije Quality svih slojeva sa Best na Draft.
• Isključivanjem prekidača Video kod svih onih slojeva koje ne želite da vidite u pregledu.
• Ograničavanjem radne površine tako da pregledom budu obuhvaćeni manji segmenti vremenske ose.

Opcije RAM pregleda Prilikom pravljenja RAM pregleda možete da eksperimentišete sa opcijama
kao što su, na primer, Frame Rate, Skip Frames ili Resolution. Ove opcije ćete pronaći u donjem delu
palete Time Controls, ispod natpisa RAM Preview Options. Ukoliko trenutno ne možete da ih vidite,
pritisnite strelicu u desnom gornjem uglu palete Time Controls kako biste otvorili meni ove palete i
zatim izaberite opciju Show RAM Preview Options.

Dodatne informacije o podešavanju pregleda možete da potražite u onlajn pomoći programa After
Effects, u odeljku „Setting preview options”.
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Povećavanje složenosti animacije
Od sasvim jednostavnog heksagonalnog elementa napravili ste relativno složenu ani-
maciju koju, menjanjem određenih svojstava, možemo da učinimo još zanimljivijom i
složenijom. Najpre ćemo rasipanjem početnih tačaka u vremenu da napravimo efekat
da svi heksagoni počinju da se pojavljuju u različitim trenucima. Nakon toga, pozaba-
vićemo se i njihovom providnošću i to tako da izblede i ostanu delimično providni.

Rasipanje početnih tačaka

Početna tačka sloja predstavlja trenutak u kome on počinje da se pojavljuje u kompozi-
ciji. Trenutno svi vaši slojevi počinju u tački 0:00 kao što možete da vidite iz obojenih
traka koje pokazuju trajanje svakog sloja u vremenu Da bismo dobili tečniju animaciju,
malo ćemo pomeriti početne tačke ovih slojeva.

1 Pritiskom dugmeta sa dvostrukom strelicom ( ) koje se nalazi na dnu vremenske
ose, otprilike na sredini ekrana, otvorite panel In/Out (početak/kraj).

Dugme Expand ili Colapse panela In/Out
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2 Izaberite podvučenu In (početak) vrednost svakog sloja, upišite novu vrednost u
okviru za dijalog Layer In Time i zatim pritisnite dugme OK. Izborom vrednosti koje su
prikazane na sledećoj ilustraciji dobićete početne tačke slojeva koje su međusobno uda-
ljene po tri kadra.

Vrednosti početnih tačaka

3 Pritiskom na taster Home, vratite marker aktuelnog vremena na poziciju 0:00 i
zatim, pritiskom razmaknice ili tastera 0 (nula) na numeričkoj tastaturi, pokrenite
reprodukciju pregleda.

4 Kada završite sa pregledanjem, ponovo pritisnite dugme sa dvostrukom strelicom
kako biste zatvorili panel In/Out prozora Timeline, a zatim pomoću komande File >
Save snimite svoj rad.

Heksagoni sada ulaze u sliku tako što redom, zdesna nalevo, zauzimaju svoje pozicije.

Podešavanje neprovidnosti jednog sloja

Ukoliko heksagone učinite poluprovidnim, njihova interakcija u formiranju šablona
pčelinjeg saća biće mnogo zanimljivija. Najpre ćemo da podesimo neprovidnost jednog
sloja i to tako da se tokom devet kadrova ublaži.

1 Pritiskom na taster Home, vratite marker aktuelnog vremena na poziciju 0:00.

2 U prozoru Timeline izaberite sloj Layer 1 i pritisnite taster T kako biste otvorili svoj-
stvo Opacity. Aktuelna vrednost ovog svojstva je 100%.

3 Povlačenjem ove vrednosti ili direktnim upisivanjem dodelite svojstvu Opacity novu
vrednost – 0 (nula).

4 Izaberite štopericu kako biste animirali ovo svojstvo i neprovidnosti prvog ključnog
kadara postavite na poziciju 0:00.

5 Pomerite marker aktuelnog vremena na poziciju 0:09.



38
Pravljenje 2D elemenata od heksagona
LEKCIJA 1
6 Povlačenjem ili direktnim upisivanjem promenite vrednost svojstva Opacity na 50%.
Nakon toga, pojavljuje se i drugi ključni kadar (na poziciji 0:09).

7 Pritiskom na taster Home, vratite marker aktuelnog vremena na poziciju 0:00, a
zatim pritisnite razmaknicu ili taster 0 (nula) na numeričkoj tastaturi kako biste pokre-
nuli reprodukciju pregleda.

Kao što možete da vidite, heksagon Layer 1 se lagano pojavljuje a zatim zadržava pro-
vidnost (neprovidnost) od 50 %.

Da biste zapamtili da je prečica na tastaturi za otvaranje svojstva Opacity taster T,
preporučujemo vam da ovo svojstvo tretirate kao transparentnost. Taster O ima drugu
primenu.

Prenošenje (kopiranje) ključnih kadrova transparentnosti na ostale slojeve

Sada isti efekat poluprovidnosti možete da prenesete i na ostale heksagone. Dodavanje
ključnih kadrova svojstva Opacity preostalim slojevima izvešćete efikasno korišćenjem
tehnike isecanja i prenošenja (kopiranje).

1 Izaberite ključne kadrove svojstva Opacity prvog sloja pažljivim povlačenjem malog
okvira oko dva ključna kadra kao što je to učinjeno na našoj ilustraciji. Isti učinak
možete da postignete i izborom reči Opacity.

2 Komandom Edit > Copy ili pritiskom na taster Ctrl + C (Windows), odnosno Com-
mand + C (Mac OS) kopirajte ključne kadrove.

3 Izaberite drugi sloj (Layer 2) i pritisnite taster I (slovo i) kako biste marker aktuelnog
vremena pomerili na početnu tačku ovog sloja (0:03).

4 Pomoću komande Edit > Paste ili pritiskom na taster Ctrl + V (Windows), odnosno
Command + V prenesite ključne kadrove svojstva Opacity na sloj Layer 2.
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5 Dok je sloj Layer 2 izabran, pritisnite taster T da biste videli nove ključne kadrove
svojstva Opacity. Ključni kadrovi se pojavljuju na vremenskim pozicijama koje
zadržavaju isti odnos prema markeru aktuelnog vremena, tako da se prvi pojavljuje na
poziciji 0:03, a drugi na poziciji 0:12. Ukoliko želite, ponovo pritisnite taster T kako
biste sakrili ove ključne kadrove.

6 Ponovite korake 3 i 4 za svaki od preostalih osam slojeva.

7 Pregledajte svoju animaciju i nakon toga snimite ovaj projekat.

Prethodno raspoređivanje većeg broja slojeva

Vaš sledeći zadatak biće objedinjavanje vaših deset slojeva u jedan postupkom koji se
naziva prethodno raspoređivanje (engl. precomposing). Ovaj nedestruktivni proces uči-
niće vaš projekat lakšim za rukovanje i omogućiće vam da dodajete transformacije
grupi kao celini.

1 Dok su prozori Timeline ili Composition aktivni, izaberite komandu Edit > Select All
kako biste izabrali svih deset slojeva.

2 Zatim izaberite komandu Layer > Pre-compose.

3 U okviru za dijalog Pre-compose upišite Hexagons Build Pre-comp što će biti naziv
ovog prethodnog raspoređivanja koji dobro opisuje ono što se događa unutar samog
procesa.
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4 Obavezno proverite da li je izabrana opcija Move All Attributes into the New Com-
position i da li je opcija Open New Composition poništena i zatim pritisnite OK.

Napomena:  Prva opcija (Leave All attributes in „Hexagn Final Comp”) treba da je nedos-
tupna (siva). Ona nije na raspolaganju kada je izabrano više slojeva.

U prozoru Timeline objekta Hexagon Final Comp sloj Hexagons Build Pre-comp zame-
njuje deset pojedinačnih slojeva sa heksagonima.

5 Pomoću komande File > Save snimite svoj projekat.

Napomena: Izborom stavke Hexagons Build Pre-comp u prozoru Project dvostrukim pri-
tiskom na levi taster miša još uvek možete da pristupite prvobitnim slojevima i izmenite
ih. Sve promene koje na ovaj način načinite u istom trenutku se prenose na objekat Hexa-
gon Final Comp.

Pa, lepo ste ovo uradili! Ovim ste završili prvu fazu konstruisanja heksagona, a to znači
da smo otprilike na polovini prve lekcije. Ukoliko želite da napravite pauzu, sada je
pravi trenutak za to – zatvorite projekat i program After Effects.
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Transformacija sloja u kojem je izvršeno prethodno raspoređivanje
Dosadašnjim radom napravili ste animirani skup heksagona koji uleće u kadar i pravi
formaciju pčelinjeg saća. Sada ćemo da se nadovežemo na to i da ispunimo čitav okvir
heksagonalnim šablonom uz dodatak nekih detalja koji će vaš rad učiniti još zanimlji-
vijim.

Nastavićemo sa transformacijom grupe heksagona koje ste do sada napravili. U tom
smislu cilj nam je dobijanje složenog kretanja u kome se objekat pomera na nekoliko
načina – rotiranjem, bočnim pomeranjem i približavanjem. Gledalac treba da dobije
utisak putovanja kroz centar jednog od heksagona.

Sada sve heksagone možete da transformišete kao celinu i to bez straha da ćete izgubiti
one prve transformacije koje ste primenili na prvobitnih deset slojeva. Nove transfor-
macije se dodaju već postojećim kretanjima i prave složene kombinacije promena
tokom vremena.

Ponovno otvaranje projekta nakon pauze

Ukoliko ste, nakon završetka prethodnog odeljka, zatvorili program After Effects, sada
ćete morati ponovo da ga otvorite zajedno sa datotekom na kojoj ste radili.

1 Pokrenite After Effects i zatim izaberite komandu File > Open Project.

2 U direktorijumu AE_CIB job koji ste napravili na početku ove lekcije pronađite
direktorijum _aep.

3 Izaberite datoteku Hexagons01_work.aep i pritisnite dugme Open.

Datoteku Hexagons01_work.aep gotovo sigurno možete da otvorite i pomoću
komande File > Open Recent Projects i zatim izborom putanje i naziva datoteke ovog pro-
jekta. Program After Effects u podmeniju Open Recent Projects obično čuva listu deset
nedavno otvaranih projekata.

4 U prozoru Project dvostrukim pritiskom na levi taster miša izaberite objekat Hexa-
gon Final Comp kako biste ga otvorili u prozorima Composition i Timeline.

Ukoliko je prozor Project pretrpan imenima koja nije najjednostavnije pročitati,
povlačenjem ispupčene trake na desnoj ivici naslova kolone možete da proširite širinu ove
kolone.
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Promena veličine i sabijanje sloja u kojem je izvršeno prethodno raspoređivanje

Najpre ćemo da podesimo veličinu heksagona i transformaciju sabijanja sloja u kojem
je izvršeno prethodno raspoređivanje, a kojom se čuva kvalitet slike. U ovom slučaju
nećete definisati ključne kadrove za promenu veličine zato što je potrebno da se svojstvo
Scale ne menja u vremenu. 

1 Pređite u karticu Hexagon Final Comp prozora Timeline ukoliko ona već nije iza-
brana.

2 Pomerite marker aktuelnog vremena na poziciju 1:00 kako biste mogli da vidite
rezultate promene veličine.

3 U prozoru Timeline izaberite sloj Hexagons Build Pre-comp i pritiskom na taster S
otvorite svojstvo Scale.

4 U okviru za dijalog Scale povlačenjem ili upisivanjem izaberite vrednost 68%. U pro-
zoru Composition grafički okvir sloja definisan je njegovim ručkama. Delovi nekih
heksagona sada nisu vidljivi.

5 Sa izabranim slojem Hexagons Build Pre-comp, pritisnite Layer > Switches >
Collapse. Isti učinak ćete postići i ako u panelu Switches prozora Timeline pritisnete
prekidač Collapse Transformations (prema podrazumevanim parametrima on se nalazi
desno od imena slojeva) i prebacite ga iz položaja Off ( ) u položaj On ( ). Ovo će vam
omogućiti da vidite deo svog dela koji se trenutno nalazi izvan grafičkog okvira, ali će i
poboljšati kvalitet sloja.

Pre (levo) i nakon (desno) uključivanja opcije Collapse Transformations

Napomena: Pojam sabijanje (uključivanje prekidača Collapse) odnosi se na način na koji
After Effects izračunava informacije o slojevima. Prilikom sabijanja transformacija
ugnežđenog sloja u kojem je izvršeno prethodno raspoređivanje, kvalitet slike se
poboljšava, a vreme potrebno za vizualizaciju konačnog snimka se skraćuje. Dodatne
informacije o ovoj temi možete da potražite u odeljcima „Maintaining image quality in
nested compositions” i „Collapsing transformation properties” onlajn pomoći programa
After Effects.
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Dupliranje i preimenovanje slojeva u kojima je izvršeno prethodno raspoređivanje

Najlakši način za ispunjavanje okvira kompozicije heksagonima jeste kopiranje sloja u
kojem je izvršeno prethodno raspoređivanje.

1 Izaberite sloj Hexagons Build Pre-comp i zatim pritisnite dugme S kako biste sakrili
svojstvo Scale.

2 Dok ste u ovom sloju, izaberite komandu Edit > Duplicate, ili pritisnite tastere Ctrl
+ D (Windows), odnosno Command + D (Mac OS).

3 Ponovo izaberite komandu Edit > Duplicate. U prozoru Timeline sada postoje tri
sloja.

4 Izaberite sloj Layer 1 i pritisnite taster Enter (Windows), odnosno Return (Mac OS).
Nakon toga ime sloja postaje aktivno, a pojavljuje se i kursor.

5 Upišite Top i pritisnite Enter (Windows), odnosno Return (Mac OS) kako biste sloju
zadali novo ime.

6 Izaberite sloj Layer 2 i ponovite korake 3 i 4 ovog postupka, a kao ime sloja upišite
Middle.

7 Na isti način sloj Layer 3 preimenujte u Bottom.
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Pomeranje slojeva u kojima je izvršeno prethodno raspoređivanje

Tri sloja koje sada imate naslagani su jedan preko drugog, tako da je u prozoru Compo-
sition vidljiv samo onaj koji se nalazi na vrhu. Sada ćete ove slojeve da pomerite tako da
formiraju kompletan šablon i popune okvir kompozicije. 

1 Pomerite marker aktuelnog vremena negde oko pozicije 2:00 kako biste mogli da
pratite svoj rad.

2 Komandom Edit > Select All izaberite sve slojeve i zatim pritisnite taster P da biste
otvorili svojstva Position.

3 Komandom Edit > Deselect All ili pritiskom na taster Ctrl + A (Windows), odnosno
Command + Shift + A (Mac OS) poništite izbor sva tri sloja.

4 Pomerite slojeve tako da se uklope ili povlačenjem (pogledajte sledeću ilustraciju) ili
upisivanjem sledećih vrednosti svojstva Position:

• Top: 449, 113

• Middle: 363, 263

• Bottom: 449, 413

5 Izaberite komandu Edit > Select All i ponovo pritisnite taster P kako biste sakrili
svojstva Position svih slojeva. Nakon toga pritisnite Edit > Deselect All.

6 Pritiskom na taster Home, vratite marker aktuelnog vremena na početak kompozi-
cije, a zatim pritisnite razmaknicu ili taster 0 (nula) da biste mogli da vidite ono što ste
do sada uradili.

7 Snimite projekat.
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Promena početnih tačaka

Vaš sledeći zadatak biće pravljenje nešto naprednijeg ulaska heksagona koji ćete dobiti
promenom početnih tačaka svakog od tri sloja, isto kao što ste to učinili sa deset origi-
nalnih slojeva.

1 U prozoru Timeline izaberite dvostruku strelicu koja se nalazi u njegovom donjem
delu kako biste otvorili panel In/Out.

2 Kao početne tačke slojeva upišite sledeće vrednosti:

• Top: 0:20

• Middle: 0:12

• Bottom: 0:04

3 Ponovo pritisnite ovo dugme kako biste zatvorili panel In/Out.

Ponovo snimite ovaj svoj projekat, a zatim, pritiskom na razmaknicu ili taster 0 (nula)
na numeričkoj tastaturi napravite RAM prethodni pregled i pogledajte šta ste do sada
uradili. Formacija se sada gradi, ne samo zdesna nalevo, već i od dna ka vrhu. 
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Prethodno raspoređivanje tri sloja

Pre nego što pređemo na neke završne detalje, ova tri sloja ćemo da konsolidujemo u
jedan sloj u kojem je izvršeno prethodno raspoređivanje.

1 Dok je prozor Timeline aktivan, pomoću komande Edit > Select All izaberite sva tri
sloja.

2 Izaberite komandu Layer > Pre-compose, nakon čega će se otvoriti okvir za dijalog Pre-
compose u kome je opcija Move All Attributes into the New Composition već izabrana.

3 U polje New Composition Name upišite Hexagon 3 Bars Pre-comp i pritisnite
dugme OK.

Napomena: Preporučuje se da celinama u kojima je izvršeno preraspoređivanje delova
uvek dajete opisna imena na osnovu kojih možete da zaključite šta se u njima dešava. Na
ovaj način izbeći ćete pretrpavanje projekta neobeleženim celinama i celinama u kojima
su delovi prethodno raspoređeni.

U prozoru Timeline sloj Hexagon 3 Bars Pre-comp zamenjuje slojeve Top, Middle i Bot-
tom. I u ovom slučaju ovim pojedinačnim slojevima možete da pristupite izborom
stavke Hexagon 3 Bars Pre-comp dvostrukim pritiskom na taster miša u prozoru Pro-
jects. Ukoliko na ovaj način otvorite neku celinu u kojoj su delovi prethodno ras-
poređeni, nemojte zaboraviti da je, pre nego što nastavite, ponovo zatvorite.

Primena trećeg nivoa kretanja i nekih drugih poboljšanja
Do sada ste napravili dva nivoa kretanja – kretanje pojedinačnih heksagona koji rotira-
jući formiraju šablon i kretanje tri trake heksagona, na kojima je izvršeno prethodno
raspoređivanje, koje u složenu celinu ulaze u različito vreme i sa različitih pozicija. Sada
ćete da transformišete novi sloj na kome je izvršeno prethodno raspoređivanje, a koji
sadrži sve radnje koje su do sada obavljene. U ovom postupku ne dolazi do gubljenja ili
brisanja transformacija koje ste primenili na slojeve koji su ugnežđeni u okviru ove
celine u kojoj je izvršeno prethodno raspoređivanje delova, već one ostaju sačuvane kao
kretanja unutar kretanja.

Nakon toga ćemo ovom sloju da dodamo još tri detalja: pomeranje tačke Anchor Point,
pravljenje kretanja koje podseća na zanošenje i ubrzavanje zumiranja

Dobijanje zumiranja 

U nastavku postupka, dramatičnim povećavanjem veličine slike napravićemo efekat
zumiranja (približavanja) kamere.

1 Pritiskom na taster Home pomerite marker aktuelnog vremena na poziciju 0:00, a
zatim u prozoru Timeline izaberite sloj Hexagon 3 Bars Pre-comp.
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2 Pritisnite taster S kako biste otvorili svojstvo Scale, a zatim, povlačenjem ili direkt-
nim upisivanjem dodelite ovom svojstvu vrednost od 92%.

3 Pritiskom na dugme u obliku štoperice napravite ključni kadar.

4 Pomerite marker aktuelnog vremena na poziciju 3:29 na jedan od sledećih načina:

• Povucite marker aktuelnog vremena sasvim udesno.

• Izaberite prikaz vremena i u okvir za dijalog Go To Time upišite vrednost 329.

• Pritisnite taster End (budući da pozicija 3:29 predstavlja poslednji kadar u složenoj
celini).

• Pomoću miša izaberite desni kraj vremenske trake (brojevi iznad trake koja u vre-
menskoj liniji pokazuje trajanje) na poziciji 3:29.

5 Sada svojstvu Scale povlačenjem ili direktnim upisivanjem dodelite vrednost 1156%.
U vremenskoj liniji se pojavljuje novi ključni kadar koji je poravnat sa markerom aktu-
elnog vremena. Neka svojstvo Scale i dalje ostane vidljivo. Prozor Composition je sada
skoro potpuno siv zato što sada izbliza gledate jedan heksagon. 

6 Pomerite marker aktuelnog vremena na poziciju 1:15. Ivice heksagona sada zbog
ekstremne promene veličine izgledaju nazubljeno.

7 U panelu Switches pritisnite prekidač Collapse ( ) kako biste sabijanjem sačuvali
kvalitet slike transformacije. Nakon sabijanja sloja ivice heksagona postaju glatke.

Pre (levo) i nakon (desno) uključivanja prekidača Collapse Transformations

Napomena: Ukoliko je rezolucija prozora Composition spuštena na vrednost Half ili neku
nižu, moguće je da vama ivice i dalje izgledaju nazubljeno. Da biste se uverili u to da su
zaista smekšane i glatke, privremeno pređite u punu (Full) rezoluciju.

8 Pomerite marker aktuelnog vremena na poziciju 0:00, a zatim, pritiskom na razmak-
nicu ili taster 0 (nula), pokrenite standardni ili RAM pretpregled.
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Sada heksagoni nakon ulaska u kadar kompozicije veoma brzo postaju veliki. U postup-
cima koji slede nastavićete sa promenama koje će izmeniti izgled vaše kompozicije.

Napomena: Moguće je da vam heksagoni u ovom trenutku izgledaju nešto većim nego što
ste očekivali. Ovo ćemo da ispravimo u jednom od narednih postupaka kako bi heksagoni
izgledali kao na probnom filmu.

Umesto da razmeru izračunava na osnovu smanjene veličine slojeva heksagona pret-
hodne kompozicije (Hexagon Build Pre-comp), After Effects u ovom slučaju u procesu
sabijanja koristi razmeru izvorne datoteke. Izvorna datoteka Hexagon01.psd je
dovoljno velika da omogući prikazivanje slike u ovoj veličini bez ikakvih posledica po
njen kvalitet.

Rotiranje čitavog pčelinjeg saća 

Sledeći korak predstavlja dodavanje rotacije koja počinje u poziciji 0:00, a završava se u
poziciji 3:29 ove kompozicije. U vezi sa tim, biće vam potrebni ključni kadrovi za rota-
ciju koje ćete postaviti u istim tačkama u vremenu u kojima ste dodali i ključne kadrove
razmere. Ovaj posao ćemo da pojednostavimo korišćenjem tehnika koje do sada niste
koristili.

1 Dok je sloj Hexagon 3 Bars Pre-comp izabran, a svojstvo Scale otvoreno, pritisnite
tastere Shift + R. Nakon toga, otvara se svojstvo Rotation, ali svojstvo Scale i dalje ostaje
na ekranu.

2 Pomerite marker aktuelnog vremena na poziciju 0:00 (ukoliko već nije na njoj), ali
sada to učinite pomoću jedne od sledećih tehnika:

• Pritisnite levu strelicu za kretanje kroz ključne kadrove svojstva Scale kako biste mar-
ker aktuelnog vremena pomerili na poziciju 0:00. Vodite računa da pri tom ne pritisnete
polje za potvrdu.

Strelica za kretanje kroz ključne kadrove

• Pritisnite taster J.
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3 Pritiskom štoperice svojstva Rotation postavite ključni kadar sa vrednostima 0 x 0°
(na poziciju 0:00).

4 U okviru svojstva Scale pritisnite desnu strelicu za kretanje kroz kadrove nakon čega
će marker aktuelnog vremena preći na sledeći ključni kadar (pozicija 3:29). Isti učinak
biste postigli i pritiskom na taster K ili taster End.

5 Promenite vrednost svojstva Rotation u 90°. U okviru svojstva Rotation sada se poja-
vljuje drugi ključni kadar.

6 Pritisnite taster J ili taster Home kako biste marker aktuelnog vremena vratili na
poziciju 0:00. 

7 Snimite projekat i onda pregledajte ovu animaciju. Ukoliko je potrebno, smanjite
rezoluciju prozora Composition da biste u RAM pretpregledu videli veći broj kadrova.

Pomeranje referentne tačke 

Nakon poslednjih promena, vaša kompozicija se povećava sve dok njen centar ne ispuni
kadar. Referentna Tačka (engl. anchor point) predstavlja fokusnu tačku zumiranja i cen-
tar rotacije. Njenim udaljavanjem od centra možete da dobijete veoma zanimljive vizu-
elne efekte (ovim se takođe priprema teren za prelazak u sledeću scenu). Za referentnu
tačku se ne definišu ključni kadrovi zato što ona kroz čitavu kompoziciju treba da
ostane na istom mestu.

1 Pomerite marker aktuelnog vremena na poziciju 3:00.

2 U panelu Switches isključite prekidač Collapse.

Napomena: Pre otvaranja objekata ili kompozicija u kojima je izvršeno prethodno ras-
poređivanje delova u prozoru Layer potrebno je isključiti opciju Collapse transformacija.
Nakon zatvaranja prozora Layer transformacija sabijanja tog sloja ponovo postaje
moguće.

3 Ili u prozoru Timeline ili u prozoru Composition dvostrukim pritiskom na levi taster
miša izaberite objekt Hexagon 3 Bars Pre-comp kako biste ga otvorili u prozoru Layer.

Končanica iznad centra sloja ukazuje na trenutnu poziciju tačke usidravanja ( ).
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4 Dok je sloj još uvek izabran, pritiskom na taster Shift + A otvorite svojstvo Anchor
Point u prozoru Timeline.

5 U prozoru Layout povucite referentnu tačku nadole i udesno do koordinata 550, 295
u čemu će vam pomoći očitavanja palete Info. Isti učinak možete da postignete povla-
čenjem ili direktnim upisivanjem vrednosti svojstva Anchor Point u prozoru Timeline.

Referentna Tačka 

6 Pritiskom malog kvadrata u okviru kartice Hexagon 3 Bars Pre-comp zatvorite pro-
zor Layer.

7 U panelu Switches ponovo uključite prekidač Collapse koji će sačuvati kvalitet sloja,
zatim snimite svoj rad i pregledajte animaciju.
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Sloj sada rotira oko nove referentne tačke, a zumiranje je usmereno na centar naznače-
nog heksagona.

Još jedna promena pozicije

Zumiranju i rotiranju sloja možemo da dodamo i malo horizontalnog ili vertikalnog
pomeranja. Mala promena pozicije daće celokupnom kretanju sloja prirodniji tok.

Pre nego što počnete, pritiskom na taster zarez (,), ili pomoću priručnog menija za uve-
ličavanje koji se nalazi u donjem levom uglu prozora Composition, smanjite nivo zumi-
ranja na sledeću nižu vrednost. Isti učinak možete da dobijete i izborom komande View
> Zoom Out. Nakon toga, na poziciji 0:00 ćete moći da vidite ceo grafički okvir sloja koji
se proteže izvan okvira kompozicije i prelazi na površinu oko njega. 

1 U prozoru Timeline pritiskom na taster Home vratite marker aktuelnog vremena na
poziciju 0:00. 

2 Izaberite sloj Hexagon 3 Bars Pre-comp i pritiskom na taster Shift + P otvorite svoj-
stvo Position ne zatvarajući svojstva Scale, Rotation i Anchor Point.

3 Povlačenjem ili direktnim upisivanjem vrednosti svojstva Position premestite sloj na
poziciju 645, 390.

4 Pritiskom na štopericu svojstva Position napravite ključni kadar.

5 Pritiskom na taster K pomerite marker aktuelnog vremena na sledeći ključni kadar
koji se nalazi na poziciji 3:29.
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6 Promenite koordinate pozicije u 314, 539 tako da centar heksagona potpuno ispuni
okvir kompozicije. Nakon toga, automatski se pojavljuje drugi ključni kadar.

7 Snimite projekat i pregledajte animaciju.

Veoma zanimljiv izgled animacije dobićete ukoliko drastično smanjite uveličavanje
(na oko 3%) i zatim pritisnete razmaknicu kako biste napravili novi pregled. Moći ćete da
vidite kretanje čitavog sloja, uključujući i konture onoga što se nalazi izvan okvira. Kada
završite sa ovim, vratite nivo uveličavanja na 50% ili neku drugu vrednost koja odgovara
veličini vašeg monitora.

Sloj na poziciji 0:00 (levo) i 1:04 (desno)

Dodavanje ubrzanja promeni veličine

U stvarnosti, kada se približavate nekom objektu, on najpre polako raste u vašem vid-
nom polju, a zatim, kada mu se značajnije približite, raste sve brže i brže. Ovu vrstu ubr-
zavanja uvek treba dodavati efektu povećavanja. Iako je reč o sasvim diskretnom efektu,
on u velikoj meri doprinosi vernosti, tako da ga vredi naučiti.
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1 Dok je svojstvo Scale vidljivo u prozoru Timeline, proširite ga pritiskom strelice.
Kada to učinite, pojaviće se dva dijagrama – Value: Scale i Velocity: Scale. Trenutno je
brzina izmene dijagrama Velocity: Scale između dva ključna kadra konstantna (line-
arna).

2 Izborom reči Scale izaberite oba ključna kadra svojstva Scale.

3 Na dijagramu Velocity: Scale (nalazi se ispod dijagrama Value: Scale) izaberite malu
ručku koja se nalazi unutar 0:00 kraja grafikona i povucite je malo nadole, a zatim ude-
sno do pozicije 2:00. Kada pustite taster miša, procentualna vrednost Velocity: Scale se
ažurira.
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4 Sada izaberite sličnu ručku blizu drugog kraja (3:29) dijagrama i povucite je malo
nadole, ali pazeći da je ne pomerite ni ulevo ni udesno. Kada je pustite, procentualna
vrednost dijagrama Velocity: Scale se ažurira. Nastavite sa povlačenjem desne ručice
nagore sve dok ne dobijete dijagram koji izgleda kao na sledećoj slici.

5 Pritiskom na taster akcenat gravis (`) sakrijte sva svojstva za transformaciju.

6 Snimite projekat i pregledajte animaciju. Sada na početku možete da vidite mnogo
više heksagona, slično onome kako se oni pojavljuju i u probnom filmu.

Skrećemo vam pažnju na to da ključni kadrovi svojstva Scale menjaju oblik nakon pro-
mene brzine. Ova pojava ukazuje na razliku u interpolaciji ključnih kadrova koju prou-
zrokuje menjanje brzine povećavanja slike. Dodatne informacije o ovoj temi možete da
potražite u segmentu „Controlling change through interpolation” onlajn pomoći pro-
grama After Effects.

Ukoliko želite da napravite još jednu pauzu, sada je pravi trenutak za to. Poslednji deo
ove lekcije trajaće između 20 i 30 minuta.

Ponovno korišćenje vašeg rada u cilju pravljenja drugog elementa
Animacija formacije pčelinjeg saća sada je završena, tako da možemo da pređemo na
izradu drugog elementa heksagona. Izrada ove nove kompozicije biće mnogo lakša zato
što ćemo se maksimalno osloniti na ono što već imamo; kopiraćemo originalnu kom-
poziciju i dodati joj neke nove elemente.

Ova mogućnost korišćenja već postojećih kompozicija umesto da se počinje ispočetka
predstavlja veliku uštedu vremena. Primera radi, moći ćete bez mnogo muke i veoma
brzo da izvršite neke sitne izmene i napravite više različitih verzija (recimo, na više
jezika ili u nekoliko izlaznih formata).
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Uvoženje grafike za potrebe drugog elementa

U postupku koji sledi najpre ćemo da uvezemo novu grafiku u vaš projekat. Ukoliko je
potrebno, ponovo pokrenite After Effects i otvorite Hexagons01_work.aep.

1 Izaberite komandu File > Import > File, ili pritisnite tastere Ctrl + I (slovo i) (Win-
dows), odnosno Command + I (Mac OS).

2 Pronađite direktorijum _psd koji ste sami napravili i u njemu datoteku Hexa-
gon02.psd koju ste kopirali sa CD-a.

3 Pritisnite dugme Open (Windows), odnosno Import (Mac OS).

4 U okviru za dijalog Interpret Footage izaberite opciju Straight – Unmatted i pritisnite
dugme OK.

5 U prozoru Project dovucite datoteku Hexagon02.psd do direktorijuma za .psd dato-
teke.

U minijaturnom prikazu videćete samo konture ovog heksagona sa malim krugovima
na svakoj njegovoj tački.

Zamena materijala

Sada ćemo da izvršimo zamenu materijala u kompoziciji.

1 U prozoru Project izaberite kompoziciju Hexagons Build Pre-comp, a zatim i
komandu Edit > Duplicate. Nakon toga, u prozoru Project pojavljuje se duplikat objekta
iza čijeg imena stoji broj dva (2).

2 Dok je izabran duplikat kompozicije, pomoću komande Composition > Composi-
tion Settings otvorite okvir za dijalog Composition Settings.

3 U odgovarajuće polje kao ime upišite HexOutlines Build Pre-comp, a sve druge
parametre ostavite neizmenjenim. Zatim pritiskom na dugme OK zatvorite okvir za
dijalog Composition Settings.
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4 U prozoru Project dvostrukim pritiskom na levi taster miša izaberite kompoziciju
HexOutlines Build Pre-comp kako biste je otvorili u prozorima Composition i Timeline.

5 Dok je prozor Timeline aktivan, pomoću komande Edit > Select All izaberite svih
deset Hexagon01.psd slojeva.

6 U prozoru Project izaberite datoteku Hexagon02.psd, a zatim, držeći pritisnut taster
Alt (Windows), odnosno Option (Mac OS), dovucite ovu datoteku u prozor Timeline i
onda pustite taster miša.

Naziv izvorne datoteke za svih deset slojeva menja se u Hexagon02.psd, a nova grafika
se pojavljuje u prozoru Composition. Da biste videli razlike, pokrenite pregled ove nove
kompozicije.

Kada u kompoziciji jednu izvornu datoteku zamenite drugom, ne morate ponovo da
definišete transformacije i ključne kadrove. Slojevi u ovom postupku zadržavaju sve
izmene svojstava za transformaciju i ključne kadrove koji se sada samo prenose na novi
materijal.

Kopiranje i ponovno korišćenje predrasporeda delova

Sada ćete prikazani postupak da ponovite i na dve preostale kompozicije ovog elementa.

1 U prozoru Project izaberite kompoziciju Hexagon 3 Bars Pre-comp i, pomoću
komande Edit > Duplicate ili pritiskom na taster Ctrl + D (Windows), odnosno Com-
mand + D (Mac OS), napravite njen duplikat. Nakon toga, u prozoru se pojavljuje i
kompozicija duplikat iza čijeg imena stoji broj 2.

2 Dok je u prozoru Project izabrana kompozicija duplikat, pomoću komande Compo-
sition > Composition Settings otvorite okvir za dijalog Composition Settings.

3 U odgovarajuće polje kao ime upišite HexOutlines 3 Bars Pre-comp, a sve druge
parametre ostavite neizmenjenim. Zatim pritiskom na dugme OK zatvorite okvir za
dijalog Composition Settings.
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4 U prozoru Project dvostrukim pritiskom na levi taster miša izaberite kompoziciju
HexOutlines 3 Bars Pre-comp kako biste je otvorili u prozorima Composition i Time-
line.

5 U prozoru Timeline izaberite sva tri sloja.

6 U prozoru Project izaberite kompoziciju HexOutlines Build Pre-comp. Zatim, držeći
pritisnut taster Alt (Windows), odnosno Option (Mac OS), dovucite izvornu datoteku
do prozora Timeline i pustite taster miša.

7 Izaberite naslov panela – Layer Name – kako biste se prebacili u panel Source Name
u kome ćete videti da su izvorna imena iz Hexagon Build Pre-comp izmenjena u Hex-
Outlines Build Pre-comp. Pregledajte kompoziciju i snimite ovo što ste upravo uradili.

Još jedno kopiranje celine u kojoj su delovi predraspoređeni

Konačno, prikazani postupak ćemo da ponovimo još jednom kako bismo dobili posled-
nju kompoziciju novog elementa.

1 U prozoru Project izaberite kompoziciju Hexagon Final Comp, a zatim pritisnite
Edit > Duplicate.

2 Izaberite dobijeni duplikat i pritiskom na tastere Ctrl + K (Windows), odnosno
Command + K (Mac OS) otvorite okvir za dijalog Composition Settings.

3 U odgovarajuće polje upišite HexOutlines Final Comp, a sve druge parametre osta-
vite neizmenjenim. Pritisnite OK.

4 U prozoru Project dvostrukim pritiskom na levi taster miša izaberite kompoziciju
HexOutlines Final kako biste je otvorili u prozorima Composition i Timeline.

5 U prozoru Timeline izaberite sloj Hexagon 3 Bars Pre-comp.
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6 U prozoru Project izaberite kompoziciju HexOutlines 3 Bars Pre-comp, a zatim,
držeći pritisnut taster Alt (Windows), odnosno Option (Mac OS), dovucite datoteku do
prozora Timeline i tek tada pustite taster miša. Ovim je sloj zamenjen.

7 Snimite ovo što ste uradili i pritisnite taster 0 (nula) da biste napravili i pokrenuli
RAM pregled animacije.

Tokom reprodukcije kompozicije obratite pažnju na to da se nove konture heksagona
ponašaju isto kao heksagoni koje su zamenili, sa istim karakteristikama veličine, pozi-
cije, rotacije i providnosti. Međutim, u animaciji je sada nova grafika.

Vizualizacija kompozicija
Vizualizacijom (procesiranjem) se od neke kompozicije dobija film u željenom formatu.
Kada budete radili na nekim velikim poslovima sa mnogo različitih komponenti,
sasvim sigurno će vam biti od pomoći da posebno izvršite predvizualizaciju nekog od
elemenata. Takav element može da se uradi kao poseban projekat ili kompozicija, da se
zatim uradi samo njegova vizualizacija kako bi se na kraju u toj formi uvezao u konač-
noj fazi rada na glavnoj kompoziciji ili projektu.

Predvizualizacija donosi nekoliko prednosti:

• Na ovaj način lakše se organizuju brojni elementi, a smanjuje se i broj kompozicija u
finalnom projektu. Zahvaljujući tome, finalni projekat postaje jednostavniji. 

• Elementi čija je predvizualizacija završena u daljem radu u mnogo manjoj meri
angažuju procesor računara od kompozicija čija vizualizacija tek predstoji. Zbog toga je
i ponovno iscrtavanje ili pravljenje pregleda kod njih znatno brže.

• Ovim pristupom se ubrzava finalna vizualizacija, zato što se jedan ovakav element
obrađuje samo kao jedan sloj, a ne kao više njih.

Oba elementa heksagona izgledaju upravo onako kako smo zamislili, što znači da je sve
spremno za vizualizaciju ovih kompozicija. Proces vizualizacije podseća na pravljenje
RAM pregleda, ali traje duže i kao krajnji rezultat daje posebnu datoteku koja može da
se snimi na disku računara.

Dužina trajanja vizualizacije zavisi od veličine i složenosti projekta, kao i od brzine rada
opreme kojom raspolažete. Ovaj projekat je relativno mali, tako da njegova vizualizacija
ne bi smela da traje duže od nekoliko minuta.

Vizualizacija elementa heksagona

Vaš prvi zadatak biće vizualizacija prve kompozicije koja se sastoji od popunjenih hek-
sagona iz datoteke Hexagon01.psd.
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1 Zatvorite prozore Timeline i Composition.

2 U prozoru Project izaberite kompoziciju Hexagon Final Comp.

3 Izaberite komandu Composition > Make Movie.

4 U okviru za dijalog Output Movie To kao ime datoteke upišite Hexagons.mov, a
zatim ovu datoteku snimite u direktorijumu _mov koji ste napravili u direktorijumu
AE_CIB job.

5 Kada pritisnete dugme Save, pojaviće se okvir za dijalog Render Queue.

U ovom postupku vizualizacije, kao i u onim koji slede u narednim poglavljima pret-
postavlja se da je u pitanju prva vizualizacija kompozicije nakon vraćanja na podrazu-
mevane parametre. Ukoliko se pre svakog postupka vizualizacije ne vratite podrazumeva-
nim parametrima, komanda Composition > Make Movie će da otvori prozor Render
Queue, a ne okvir za dijalog Output Movie To. Ako se, nakon zadavanja komande Make
Movie pojavi prozor Render Queue, izaberite podvučene reči pored opcije Output To kako
biste otvorili okvir za dijalog Output Movie To i onda nastavite sa korakom 4 onako kako
je opisano.

6 Mišem izaberite podvučene reči Current Settings koje se nalaze pored opcije Render
Settings.

7 U okviru za dijalog Render Settings navedite sledeće opcije:

• Kod opcije kvalitet izaberite Best.

• Kod opcije Resolution izaberite Full.

• U okviru opcije Time Sampling za parametar Time Span iz priručnog menija izaberite
Length of Comp.

(Ovi parametri će nadvladati sve one koje ste za potrebe vizualizacije naznačili u pro-
zorima Composition i Timeline.)
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8 Pritiskom na dugme OK zatvorite okvir za dijalog Render Settings.

9 U prozoru Render Queue pritiskom na strelicu otvorite priručni meni opcije Output
Module i u njemu izaberite Custom.
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10 U okviru za dijalog Output Module Settings u delu Output Module izaberite sledeće
opcije:

• Iz priručnog menija Format izaberite format QuickTime Movie.

• Iz priručnog menija Post-Render Action izaberite akciju Import.

11 U delu Video Output pritisnite dugme Format Options kako biste otvorili okvir za
dijalog Compression Settings. U njemu treba da budu izabrane sledeće opcije:

• U delu Compressor iz odgovarajućih menija izaberite opcije Animation i Millions of
Colors+.

• Klizač Quality pomerite sasvim udesno.

Napomena: Vrednost Frames per Second podešava se u okviru za dijalog Render Settings
a ne ovde.
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12 Pritiskom na dugme OK zatvorite okvir za dijalog Compression Settings.

13 Ponovo pritisnite dugme OK kako biste zatvorili i okvir za dijalog Output Module
Settings i vratili se prozoru Render Queue.

14 Pomoću komande File > Save snimite još jednom projekat pre vizualizacije i onda
pritisnite dugme Render.

Napomena: Iako ste pre vizualizacije kompozicije Hexagons Final Comp mogli da nazna-
čite i opcije za vizualizaciju kompozicije HexOutlines Final Comp, ova vizualizacija će
vam pružiti dobar uvid u to koliko dugo ovaj proces traje na vašem računaru.

Vizualizacija elementa HexOutlines

Zatim ćemo da izvršimo vizualizaciju elementa HexOutlines.

1 U prozoru Project izaberite kompoziciju HexOutlines Final Comp, a zatim i
komandu Composition > Make Movie. Nakon toga otvara se prozor Render Queue sa
kompozicijom HexOutlines Final Comp kao drugom stavkom u redu za vizualizaciju.

2 Izborom reči HexOutlines Final Comp.mov koje se nalaze pored opcije Output To
otvorite okvir za dijalog Output Movie To.

3 Kao ime filma u polje File Name upišite HexOutlines.mov i snimite ga u direktori-
jum _mov koji ste napravili u direktorijumu AE_CIB job. Zatim pritisnite dugme Save
kako biste se vratili u prozor Render Queue.

4 Ponovite korake od 6 do 14 prethodnog postupka „Vizualizacija elementa heksa-
gona” koji je opisan na strani 58.

5 Nakon završetka vizualizacije, zatvorite prozor Render Queue.
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6 Filmovi Hexagons.mov i HexOutlines.mov pojavljuju se u prozoru Project zato što
ste u koraku 10 na strani 61 kod opcije Post-Render Action izabrali akciju Import.

Pregledanje dobijenih filmova

Stigli smo i do samog kraja ove lekcije – preostalo je još samo da pogledate šta ste vizu-
alizacijom dobili.

1 U prozoru Project dvostrukim pritiskom na levi taster miša izaberite film Hexa-
gons.mov.

2 Zatim, pritiskom dugmeta Play ( ) pokrenite njegovu reprodukciju.

3 Ponovite korake 1 i 2 za film HexOutlines.mov.

4 Kada završite, zatvorite prozore za reprodukciju.

Moguće je da ćete nakon vizualizacije filma želeti da izmenite neke njegove elemente.
Ukoliko je tako, izmenite odgovarajuće kompozicije i snimite to što ste uradili. Imajte u
vidu to da te izmene nećete imati u filmu čiju ste vizualizaciju upravo završili. Dakle,
nakon eventualnih izmena, moraćete da izvršite još jednu vizualizaciju ovih kompozi-
cija. Dodatne informacije o ovoj temi možete da potražite u odeljku „Saving time by
pre-rendering nested compositions” onlajn pomoći programa After Effects.
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Ukoliko imate problema sa pregledanjem filmova u punoj rezoluciji, pokušajte da,
samo za sebe, izvršite vizualizaciju u upola nižoj rezoluciji. Da biste to učinili, ponovite
prethodnu proceduru, s tom razlikom što ćete sada kao ime u koraku 4 da upišete Hexa-
gon_lr.mov i što ćete u koraku 7 pod opcijom Resolution, umesto Full, da izaberete Half.
Međutim, ako uradite vizualizaciju u nižoj rezoluciji, nikako nemojte brisati verziju u
punoj rezoluciji. U finalnom projektu prilikom kombinovanja elemenata možete da kori-
stite samo verzije u punoj rezoluciji – verzije u upola nižoj rezoluciji nemaju neophodne
dimenzije.

Čestitamo! Rad na elementima Hexagons.mov i HexOutlines.mov je završen. Kasnije
ćemo kombinovanjem ovih QuickTime elemenata sa još nekim koje ćemo napraviti u
nastavku knjige dobiti našu finalnu kompoziciju.
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