UPOZNAVANIJE

Pregled lekcije

U ovoj lekciji naucicete kako da uradite sledece:

Kreirate nove datoteke u Flashu

Podesavate pozornice u panelu Property

Dodajete slojeva vremenskoj liniji

Manipuli$ete klju¢nim kadrovima u vremenskoj liniji
Radite sa slikama koje su uvezene u biblioteku
Pomerate i postavljanje objekata na pozornici
Otvarate i rad sa panelima

Odaberete i upotrebite alate u alatnom panelu
Pregledate vase Flash animacije

Trazite teme u pomoc¢nom meniju Flasha

Pristupate onlajn Flash resursima

Da bi se zavrsila ova lekcija, potrebno je manje od jednog sata.
Kopirajte fasciklu Lesson01 sa CD-a Adobe Flash CS4 Professional
na va$ hard disk, u slucaju da ve¢ nije na disku.
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U Flashu pozornica predstavlja mesto desavanja radnje. Vremenska linija
organizuje kadrove i slojeve, dok vam drugi paneli dozvoljavaju da preprav-
ljate i kontrolisete vasu kreaciju.




Pokretanje Flasha i otvaranje datoteke

Prilikom prvog pokretanja Flasha, videcete startni meni sa linkovima ka standardnim
$ablonima datoteka, priru¢nicima, i drugim resursima. U ovoj lekciji, napravicete jedno-
stavnu animaciju da biste prikazali nekoliko brzih snimaka koji za temu imaju godi$nji
odmor. Dodavacete fotografije i natpis i pri tom cete nauciti kako da pozicionirate ele-
mente na pozornici a takode i da ih razmestite duz vremenske linije.

1 Pokrenite Adobe Flash. U Windowsu, izaberite Start > All Programs > Adobe Flash
CS4. Za operativne sisteme Macintosh, dvaput pritisnite Adobe Flash CS4 u fascikli
Application ili Dock.

Napomena: Mozete takode pokrenuti Flash ukoliko dva puta pritisnite datoteku sa ekstenzijom .fla

2 Izaberite File > Open. U polju Open dialog, izaberite datoteku 01 End.swf u fascikli
LessonO01 i pritisnite Open da biste videli izgled zavr§enog projekta.

Animacija se pokrec¢e. Tokom animacije nekoliko preklapajucih slika se smenjuje i
one se zavrsavaju natpisom.

3 Zatvorite prozor za pregled.

4 Izaberite File > new. U polju New Document, izaberite Flash datoteku (Action Script
3.0)

Action Script 3.0 je najnovija verzija Flashovog skript jezika, koji se koristi da bi se
dodala interakcija. Za ActionScript 3.0 va$ pretrazivac treba da ima instaliranu verziju
Flash Playera 9 ili noviju. U ovoj lekciji necete raditi sa ActionScriptom, ali Cete ipak
morati da odaberete verziju sa kojom je vasa datoteka kompatibilna.
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5 Izaberite File > Save. Dodelite ime datoteci 01_workingcopy.fla i sacuvajte je u fas-
cikli 01Start. Preporucuje se da odmah sacuvate svoju datoteku kako biste bili sigurni
da se vas rad nece izgubiti u slu¢aju pada operativnog sistema ili nefunkcionisanja
aplikacije. Trebalo bi uvek sacuvati Flash datoteku sa ekstenzijom .fla kako biste je
identifikovali kao Flash datoteku.

Upoznavanje sa radnom povrsinom

Radna povrsina Adobe Flasha sadrzi komandne menije u vrhu ekrana kao i mnostvo alata
i panela potrebnih za prepravljanje i dodavanje elemenata vasem filmu. Mozete kreirati
sve objekte za vasu animaciju u Flashu, a takode mozete uvesti elemente koje ste kreirali
u Adobe Illustratoru, Adobe Photoshopu, Adobe After Effects, ili drugim kompatibilnim
aplikacijama.

Podrazumevana podes$avanja su, da Flash prikazuje meni, vremensku liniju, scenu, panel
sa alatima, panel Property, i nekoliko drugih panela. Tokom rada u Flashu, mozete otva-
rati, zatvarati, usidriti, odvajati od bazne pozicije, i pomerati panele duz ekrana. Da biste
se vratili na osnovnu radnu povrsinu, izaberite Window > Workspace > Essentials.
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O pozornici

Veliki beli pravougaonik u sredini vaseg ekrana je pozornica. Poput pozornice u pozo-
ri$tu, pozornica u Flashu je mesto gde gledaoci posmatraju film. Ona sadrzi tekst, slike,
i video zapis koji se pojavljuju na ekranu. Pomerajte elemente na pozornici i izvan nje
da biste ih imali u vidokrugu ili izvan njega. Mozete koristiti lenjire (View > Rulers) ili
koordinatne mreze (View > Grid > Show Grid) da biste postavili objekte na pozornicu.
Pored ovoga, kao mogucénost za koris¢enje imate i panel Align i druge alatke o kojima
Cete uditi u narednim lekcijama.

Podrazumeva se da Cete videti sivu povrsinu izvan pozornice gde mozete postaviti ele-
mente koji nisu vidljivi za posmatrace (zato $to su izvan pozornice). Naziv za sivu povr-
$inu je pomoc¢na radna povrsina (engl. Pasteboard). Ako Zelite da vidite samo pozornicu,
izaberite View > Pasteboard i uklonite znak potvrde. Za sada, ostavite znak potvrde za
ovu opciju.

Da biste odredili proporcije pozornice
tako da njena veli¢ina potpuno odgo- & & haw |
vara veliCini prozora, izaberite View > '

Fit in Window
Show Frame

. . e, . . v Show All
Magnification > Fit in Window. MozZete San itled-1
takode izabrati razlicite vrednosti uve- 0%

100%
¢anja u padaju¢em meniju koji se nalazi 200% h Player 10
iznad pozornice. 400% -

P A00% _onS{rlpt 3.0

Menjanje svojstava pozornice

Kao prvo, podesite boju i dimenzije

. . FROFPERTIES
pozornice. Ove opcije se nalaze u panelu

Property, koji je zapravo vertikalni panel Fl Bl &
desno od pozornice. 01_workingcopy.fla R
L]

1 U dnu panela Property uocicete da su ST 9
dimenzije trenutne pozornice pode- Player: Flash Player 10 =)
$ene na 550x 400 piksela. Pritisnite Script: ActionScript 3.0 A
dugme Edit. Class: | | 2 T
Pojavljuje se dijalog sa svojstvima Profile: Default £
dokumenta. — =
AlR Settings Edit... _f‘

=> PROPERTIES

i

FPS: 12.00 5

Size: 550 x 400 px Edit... -f-'q.

Stage: |:| Document properties

Y
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2 U poljima Width i Height unesite nove vrednosti piksela. U polje Width unesite vred-
nost 400, a u polje Height vrednost 250.

3 Pritisnite dugme Background color i izaberite novu boju za pozornicu. Izaberite
tamnosivu boju (dark grey) #333333.

Document Properties

Dimensions: 400 px (width) X 250 px ) (height)

W Adjust 3D Perspective Angle to preserve current Stage projection
Match:  (7) Printer Contents @) Default

Background color: |E

Frame rate: |12 fps
Ruler units: | Pixels k5
( Make Default ) ( Cancel )

4 Pritisnite dugme OK. Vasa pozornica je sada dobila nove dimenzije i boju. Mozete
promeniti boju pozornice tako $to Cete pritisnuti dugme Stage u Property inspectoru.
Sto se tice svojstava pozornice, mozete ih promeniti u bilo kom trenutku.

Napomena: Naucicete vise o simbolima u lekciji 3.

Rad sa panelom Library

Ovom panelu mozete pristupiti pomocu kartice koja se nalazi desno od panela Property.
Panel Library je mesto gde cuvate i organizujete vase simbole koje ste kreirali u Flashu,
kao i uvezene datoteke ukljucujuci rastersku grafiku, grafiku, zvucne zapise i video kli-
pove. Simboli predstavljaju grafiku koja se ¢esto upotrebljava za animaciju i interaktiv-
nost.

O panelu Library

Panel Library vam pruza moguc¢nost da organizujete objekte u fascikle, da vidite koliko
Cesto se koristi neki objekat u dokumentu, kao i da sortirate objekte po tipu. Ukoliko
uvozite objekte u Flash, mozete ih ubaciti direktno na pozornicu ili u panel Library.
Medutim, svaki objekat koji se uvozi na pozornicu istovremeno se dodaje i biblioteci, kao
i svaki simbol koji kreirate. Ovo vam pruza mogucnost da lako pristupite objektima kako
biste ih ponovo dodali pozornici, modifikovali ili pogledali njihove karakteristike.

Da biste dobili prikaz panela Library, izaberite Window > Library, ili pritisnite tastere
CTRL+L (Windows) ili Command+L (Mac OS).
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Uvoz objekta u panel Library

Cesto cete kreirati graficke prikaze direktno pomocu alata za crtanje i ¢uvacete ih kao
simbole u biblioteci. Takode, uvozicete JPEG slike ili MP3 datoteke koje se isto tako
¢uvaju u biblioteci.

U ovoj lekciji, ubacicete nekoliko JPEG slika u biblioteku da bi ih kasnije koristili u ani-
maciji.
1 Izaberite File > Import > Import to Library. U okviru za dijalog Open izaberite dato-
teku background.jpg u fascikli Lesson01/01Start i pritisnite Open.
2 Flash uvozi izabranu JPEG sliku i smesta je u panel Library.
3 Nastavite sa uvozom ostalih JPEG slika iz omotnice 01Start.

4 Panel Library prikazuje sve uvezene JPEG slike sa njihovim nazivima i njihov umanjeni
prikaz. Ove slike su vam sada dostupne za kori$¢enje u vasem Flash dokumentu.

4 jtems & | |

i Name 4 | Linkage
background.jpg

@ photol.jpg

(] photo2.jpg

photo3.jpg

Dodavanje objekta iz panela Library na pozornicu

Da biste koristili uvezenu sliku, jednostavno je prevucite iz panela Library na pozor-
nicu.

1 Izaberite Window > Library da biste otvorili panel Library ukoliko nije otvoren.

2 Izaberite objekat background.jpg iz panela Library.
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3 Prevucite objekat background.jpg na pozornicu i smestite ga priblizno u srediste
pozornice.

LIBRARY

& & (oo ® [[01_work

=~

ingcopy.fla

o) 3@

Y —

Name | Linkage
@ background.jpg
@ photol.jpg
photoZ2.jpg
[#] photo3.jpg

Razumevanje vremenske linije

Vremenska linija se nalazi ispod pozornice. Poput filmova, Flash dokumenti mere vreme
u kadrovima. Dok film traje, kliza¢ na vremenskoj osi, prikazan u vidu crvene vertikalne
linije, napreduje kroz kadrove na vremenskoj liniji. MoZete promeniti sadrzaj pozornice
za razlicite kadrove u vremenskoj liniji. Da biste prikazali sadrzaj kadra na pozornici,
pomerite kliza¢ na vremenskoj osi ka tom kadru.

U dnu vremenske linije, Flash prikazuje broj izabranog kadra, trenutnu brzinu kadra (broj
kadrova u sekundi), kao i vreme koje je proteklo od pocetka filma.

Vremenska linija takode sadrzi slojeve koji vam pomazu da organizujete vase umetnicko
delo u dokument. Zamislite slojeve kao visestruke trake koje su naslagane jedna na drugu.
Svaki sloj sadrzi razli¢itu sliku koja se pojavljuje na pozornici, tako da mozete crtati i
prepravljati objekte na jednom sloju a da pri tom ne menjate objekte na nekom drugom
sloju. Slojevi su poredani po redosledu pojavljivanja na vremenskoj liniji, $to znaci da
su objekti pri kraju vremenske linije takode i na dnu gomile sa objektima na pozornici.
Slojeve mozete sakriti, prikazati, zakljucati ili otkljucati. Kadrovi svakog sloja su jedin-
stveni, ali ih mozete prevuci na drugu lokaciju na istom sloju ili ih kopirati i premestiti
na neki drugi sloj.

ADOBE FLASH CS4 PROFESSIONAL UCIONICA U KNJIZI 9



Preimenovanje slojeva

Predlazemo vam da va$ sadrzaj razdvojite na vise slojeva i da imenujete svaki sloj tako da
lako mozete nadi sloj kada vam zatreba.

1 Izaberite postojeci sloj na vremenskoj liniji.

2 Pritisnite dva puta naziv sloja da biste ga preimenovali i ukucajte background.

3 Pritisnite pokazivacem vaseg mi$a izvan polja sa imenom da biste primenili novo

ime.
& a 0 5 10 15 20 25
background %
B O @ (RN "R OR! 120fs 00s

4 Pritisnite crnu tacku koja se nalazi ispod ikone sa katancem da biste zakljucali sloj.
Zakljucavanje sloja vas onemogucava da sluc¢ajno napravite izmene na tom sloju.

TIMELINE

™ background

Bl & @ MY Mok 12.0fps  0.0s

Dodavanje sloja

Novi dokument u Flashu sadrzi samo jedan sloj, ali vi mozete dodati onoliko slojeva
koliko vam je potrebno. Objekti u gornjim slojevima preklapaju objekte u donjim.

1 Izaberite sloj background na vremenskoj liniji.
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2 Izaberite Insert > Timeline > Layer. Takode, mozete pritisnuti dugme Add new Layer
koje se nalazi ispod vremenske linije. Novi sloj se pojavljuje iznad pozadinskog sloja.

H 8 Modify Text Commands Control

New Symbol... 3EFs
Motion Tween

Shape Tween
Classic Tween

Timeline

F5

Keyframe
Blank Keyframe

3 Da biste imenovali sloj, pritisnite dva puta novi sloj i ukucajte photo1l. Da biste prime-
nili novo ime, pritisnite izvan polja za ime. Vasa vremenska linija sada ima dva sloja.
Pozadinski sloj sadrzi pozadinsku fotografiju, dok je novi sloj photol prazan.

4 Izaberite gornji sloj pod imenom photol.
5 Izaberite Window > Library da biste otvorili panel Library u slu¢aju da nije otvoren.
6 Prevucite objekat iz biblioteke pod imenom photol.jpg na pozornicu.

Photol JPEG se pojavljuje na pozornici i preklapa background JPEG.

™ photol ¥
9] background « 8 o)
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7 lzaberite insert > Timeline > Layer ili pritisnite dugme Add new Layer (@l) koje se
nalazi ispod vremenske linije da biste dodali tre¢i sloj.

8 Dodelite ime tre¢em sloju Photo2.

TIMELINE

= photo2 &
4l photol . e .
@l background « 8 |:|.

Rad sa slojevima

U slucaju da vam sloj vise nije potreban, mozete ga lako obrisati tako Sto cete ga oznaditi a zatim
pritisnuti dugme Delete Layer koje se nalazi ispod vremenske linije.

= photo2
&l photol . . .
@l background « @ @ !
| [§ mE W1 120fs 00s

Ukoliko Zelite da razmestite slojeve, jednostavno odaberite bilo koji sloj i prevucite ga u novi polo-
Zaj u skupini slojeva.

Ubacivanje kadrova

Za sada, imate pozadinsku fotografiju i jo$ jednu preklapaju¢u na pozornici. Medutim, u
vasoj animaciji postoji samo jedan kadar. Da biste dodali vi$e vremena vremenskoj liniji,
morate dodati jo$ kadrova.

1 Izaberite kadar 48 na sloju background.
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TIMELINE

a0 s 1 PR B 1 R L TR L
@l photo2 « « [ !
4l photol o o @
™ background [ k
B O@ ] f & Wil 120fps 00s [€] I

2 Izaberite Insert > Timeline > Frame (F5). Mozete takode koristiti desni taster misa
(za Windows) ili CTRL i pritisak miSem — (za Macintosh) i izabrati Insert Frame iz
menija koji se pojavljuje.

Flash dodaje kadrove na pozadinskom sloju do izabrane tacke — kadra 48.

TIMELINE

a0 s 10 15 20 25 30 35 40 45 |50
&l photo2 v o W
&l photol v o« [
backgrounc N |

= ] 1% % 5 %0l 48 120fs 38s [4] I

3 Izaberite kadar 48 na sloju photol.

4 Izaberite Insert > Timeline > Frame (F5). Takode mozZete Koristiti desni taster misa,
odnosno CTRL i pritisak mi$a i da iz menija izaberete Insert Frame.

Flash dodaje kadrove na pozadinskom sloju do izabrane tacke — kadra 48.

5 Izaberite kadar 48 na sloju photo2 i ubacite kadrove na ovom sloju.

=@ 0L 5 10 15 20 25 30 35 40 45 50
phnoto AR 1 RENR
4] photol o+ M
4l background - @ O
Bl O )4 G & W [7 48  120fs 38s [A] I

Sada imate tri sloja sa 48 kadrova na vremenskoj liniji. Posto je brzina kadra vaseg Flash
dokumenta 12 kadrova u sekundi, to znaci da vasa sadasnja animacija traje 4 sekunde.

ADOBE FLASH CS4 PROFESSIONAL UCIONICA U KNJIZI
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Biranje vise slojeva

Kao sto birate viSe datoteka na vasoj radnoj povrsini drzanjem tastera Shift, isto tako mozete drzati
ovaj taster kako biste izabrali viSe kadrova na vremenskoj liniji u Flashu. Ukoliko imate vise slojeva
u koje Zelite da ubacite kadrove, drZite taster Shift i pritisnite tacku u koju Zelite da dodate kadrove
za sve slojeve. Zatim, izaberite Insert > Timeline > Frame.

Kreiranje klju¢nog kadra

Kljucni kadar oznacava promenu sadrzaja pozornice. Klju¢ni kadrovi su prikazani na
vremenskoj liniji u obliku kruzi¢a. Ukoliko je kruzi¢ prazan, to znaci da se u tom trenutku
nista ne nalazi na tom sloju. Kruzi¢ crne boje ukazuje na ¢injenicu da se ne$to u tom
trenutku nalazi na tom sloju. Na primer, sloj background sadrzi pun klju¢ni kadar (crni
kruzi¢) u prvom kadru. Sloj photol takode sadrzi pun klju¢ni kadar u prvom kadru. Oba
sloja sadrze slike. Medutim, sloj photo2 sadrzi prazan klju¢ni kadar u prvom kadru, $to
znaci da je trenutno prazan.

Ubacicete klju¢ni kadar na sloj photo2 u onaj vremenski trenutak u kom zelite da se
pojavi sledeca slika.

1 Izaberite kadar 18 na sloju photo2. Nakon $to odaberete kadar, Flash prikazuje broj
kadra ispod vremenska linije.

TIMELINE
T af: 5 10 15 20 25 30 35 40 45 50
= photo2 e . L T LR a1
@l photol . + Hfs o
4l background . am, 7
Eoa M) ™%l 18  120fs 14s [|] I

2 Izaberite Insert > Timeline > Keyframe (F6).

Na sloju photo2 u kadru 18, pojavljuje se novi klju¢ni kadar koji je prikazan praznim
kruzi¢em.

TIMELINE

= a8 01 5 10 15 20 25 30 35 40 45 50
Rl ARIRSIGANeRaRNE 4 dU L]
&l photol o« @, i
9l background « @ [, i

|
o
Eo

i W[ 18 120 14s [W] I
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3 Izaberite novi klju¢ni kadar u kadru 18 na sloju photo2.
4 Prevucite objekat photo2.jpg iz biblioteke na pozornicu.

Prazan kruzic¢ u kadru 18 postaje pun $to znaci da dolazi do promene na sloju photo2.
Na pozornici se pojavljuje jo$ jedna slika u kadru 18. MozZete pritisnuti i vudi kliza¢
na vremenskoj osi od pocetka vremenske linije da biste obelezili ili prikazali sta se
dogada na pozornici u bilo kojoj tacki vremenske linije. Primeticete da pozadinska
slika i photol ostaju na pozornici tokom c¢itave vremenske linije dok se photo2 pojav-
ljuje u kadru 18.

Razumevanje kadrova i klju¢nih kadrova su osnov za savladavanje Flasha. Uverite se da
li razumete zasto sloj photo2 sadrzi 48 kadrova i 2 klju¢na kadra — jedan prazan u kadru
1ijedan pun klju¢ni kadar u kadru 18.

@ 0Or s 10 15 1 20 25 30 35 40 45 50
al photo2 N o i
4l photol s i
9l background « @ A 0
al O M4 &Sl 8 120fs 14s [E]

Pomeranje klju¢nog kadra

Ako zelite da se vasa slika photo2.jpg pojavi ranije ili kasnije, trebalo bi da pomerite
klju¢ni kadar u kome se pojavljuje ova slika napred ili nazad na vremenskoj liniji. Svaki
klju¢ni kadar mozete jednostavno pomeriti na vremenskoj liniji tako $to Cete ga izabrati
a zatim prevuci na novu poziciju.
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1 Izaberite klju¢ni kadar u kadru 18 na sloju photo2.

2 Pomerajte lagano pokaziva¢ miSa i videcete pravougaonu ikonicu koja se pojavljuje
pored vaseg pokazivaca, §to vam govori da mozete premestiti kljucni kadar.

3 Pritisnite i prevucite klju¢ni kadar do kadra 12 na sloju photo2.

s @ 0. 5 10 15 20 25 30 35 40 45 50
photo ] 'IL - IDE IIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII
4l photol o o Eh W
4l background « @ .
R O® 1% G & %] 18 120fps la4s [€] |

Photo2.jpg se sada pojavljuje na pozornici dosta ranije u animaciji.

= a0 5 10 15 20 25 30 35 40 45 50
T
4l photol + » Hfs
4l background « @ .

R O® M4 Gn Wl 12  120fes 095 [N

Uklanjanje klju¢nih kadrova

Ako Zelite da uklonite klju¢ni kadar, ne pritiskajte taster Delete! Ukoliko to uradite, izbrisacete sadr-
Zaj tog klju¢nog kadra na pozornici. Da biste pravilno uklonili klju¢ni kadar, izaberite ga i koristite
komande Modify > Timeline > Clear Keyframe (Shift+F6). Na ovaj nacin ste uklonili klju¢ni kadar iz
vremenske linije.

Organizovanje slojeva u vremenskoj liniji

Za sada, vasa Flash datoteka ima samo tri sloja: sloj background, sloj photol, i sloj photo2.
Dodavacete dodatne slojeve vasem projektu tako da ¢ete na kraju morati da upravljate sa
vi$e slojeva. Fascikle za slojeve vam pomazu da grupi$ete srodne slojeve kako biste lakse
organizovali i upravljali vaSom vremenskom linijom. Kao slican primer, mozemo navesti
postupak pravljenja fascikli za srodne dokumente na vasoj radnoj povrsini. lako ¢e vam
biti potrebno nesto vise vremena da napravite fascikle, na ovaj nacin cCete ustedeti vreme
zato $to Cete kasnije ta¢no znati gde da trazite odredeni sloj.

16 LEKCUJA1 Upoznavanje



Pravljenje fascikli za slojeve

U ovom projektu, nastavic¢ete da dodajete slojeve za dodatne slike, i slojeve Cete smestati

u fasciklu za slojeve.
1 Izaberite sloj photo2 i pritisnite dugme Add New
2 Imenujte ovaj sloj photo3.

3 Ubacite klju¢ni kadar u kadar 24.
4

Prevucite photo3.jpg iz biblioteke na pozornicu.

Layer (&l).

Sada imate Cetiri sloja. Prva tri sloja sadrze slike scena iz filma Coney Island koje se
pojavljuju u razlicitim klju¢nim kadrovima.

@ 0L 5 10 15 20 30 A5 40 45 50
al photo3 2+« H. il
4l photo2 « o« @, |:|J3 i
@l photol o o+ M 0
] background « @ [, i
BO@ % & W28 I120fks 195 [A] [

Izaberite sloj photo3 i pritisnite ikonu za fasciklu

=).

sloja (

Iznad sloja photo3 pojavljuje se nova fascikla za sloj.

6 Imenujte ovu fasciklu photos.

s a8 0O 5 10 15 20 5 30 35 40 45 50
photos |
Sl photo3 e s @l DH q
@l photo2 « o« @ ng 0
@l photol o o« M 0
] background « @ Wiy ]
Bl O@ My mB Wl 22 120 19s [ I
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Dodavanije slojeva fasciklama sloja

Sada cete dodati nove slojeve slika fascikli photo. Dok razmestate slojeve, imajte na umu
¢injenicu da Flash prikazuje slojeve po redosledu pojavljivanja na vremenskoj liniji, tako
da se gornyji sloj nalazi napred a donji nazad.

1 Prevucite sloj photol u fasciklu photo.

Primeticete tamnu liniju koja oznacava odrediste vaseg sloja. Kada je sloj smesten
unutar omotnice, ime sloja postaje uvuceno.

TIMELINE

s @ 0L 5 10 15 20 5 30 35 40 45 50
¥ & photos « « @ |
a photo3 K e+ W
&l photo2 +« H
] background |
o= ] My mBSE 22 120 195 [ I

2 Prevucite sloj photo2 u fasciklu photo.
3 Prevucite sloj photo3 u fasciklu photo.

Sva tri sloja bi sada trebalo da budu u fascikli photo.

TIMELINE

¥ & photos .
al photo3 .
4l photo2 .

&l photol
] background

& & [0 |2

& O@ |4 5 & %] 48 120fps 39s [€] |

Mozete sazeti folder pritiskom na strelicu. Prosirite fasciklu ponovnim pritiskom na stre-
licu. Vodite racuna da ako izbrisete fasciklu sa slojevima, u tom slucaju Cete izbrisati sve
slojeve koji se nalaze unutar te fascikle.

Menjanje izgleda vremenske linije

Mozete podesiti izgled vremenske linije tako
da on odgovara vasem radu. Kada zelite da

vidite viSe slojeva, izaberite Short iz menija
Frame View koji se nalazi u gornjem desnom
uglu vremenske linije. Komanda Short sma-
njuje visinu redova u kadru.

Medium
Large
Preview
Preview in Context

Short
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Mozete menjati Sirinu Celije kadra tako $to birate opcije Tiny, Small, Normal, Medium
ili Large.

Koris¢enje panela Property

Panel Property vam pruza brz pristup onim svojstvima koja ¢e vam biti potrebna. Sta ¢e
se pojaviti u panelu Property zavisi od toga $ta ste izabrali. Na primer, u slucaju da nista
niste izabrali, panel Property prikazuje opcije za standardni Flash dokument koje uklju-
¢uju promenu boje i dimenzija pozornice. Ukoliko je izabran neki objekat na pozornici,
tada panel Property prikazuje koordinate x i y tog objekta. Koristi¢ete panel Property da
biste premestili slike na pozornicu.

Postavljanje objekta na pozornicu

Ovaj postupak cete zapoceti premestanjem slika pomoc¢u panela Property. Takode cete
koristiti panel Transform da biste rotirali slike.

1 U kadru 1 vremenske linije izaberite sloj photol.jpg, koji ste prevukli na pozornicu iz
sloja photol. Plava kontura vam ukazuje na objekat koji je izabran.

2 U panelu Property ukucajte 30 za vrednost X i 0 za vrednost Y. Pritisnite Enter/
Return da biste primenili ove vrednosti. Mozete pritisnuti miSem i prevuci pokazivac
vaseg misa preko vrednosti X i Y da biste promenili njihov polozaj. Slika se pomera
prema levoj strani pozornice.

|
5 & oo 8]
Bitmap
r
Instance of: photol.jpg

=~ POSITION AND SIZE

X 30.0 N

Vrednosti XiY se mere na pozornici od gornjeg levog ugla. Vrednost za X pocinje od
0 i povecava se udesno, dok vrednost za Y takode pocinje od 0 ali se povecava nadole.
Tacka registracije za uvezene slike se nalazi u gornjem levom uglu.

3 Izaberite Window > Transform da biste otvorili panel Transform.
Napomena: Ukoliko panel Propertynije otvoren, izaberite Window > Properties > Properties, ili

pritisnite CTRL/Command+F3.
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4 U panelu Transform izaberite Rotate i u polje Rotate ukucajte -12, ili pritisnite i pre-
vucite pokaziva¢ preko vrednosti kako biste izmenili rotaciju. Pritisnite Enter/Return
da biste primenili vrednost.

TRANSFORM OM AND SIZE
+ 100.0% § 100.0%0 Constrain | X: 6.2 v: -18.1
© Rotate 4 W 247.7 H: 286.1

Oskew 27 00° Hooe

3D Rotation
x RO* ¥ 80° =z 0.0°

x 0.0 ¥y 0.0 z Q.0

5 U sloju photo2 izaberite kadar 12. Sada pritisnite pokazivacem photo2.jpg na pozor-
nici.
6 Koristite panel Property i panel Transform kako biste postavili i rotirali drugu sliku

na zanimljiv nacin. Koristite sledece vrednosti: X=40, Y=0, za Rotate vrednost 8, da
biste dobili kontrast u odnosu na prvu sliku.

PROPERT

[

Instance

B & o H

TRANSFORM

@ Rotate 4

O Skew 7 -° G-

3D Rotation

a0 y: 0.0 z 0.0

7 U sloju photo3 izaberite kadar 24. Sada pritisnite pokaziva¢em photo3.jpg na pozor-
nici.
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8 Koristite panel Property i panel Transform kako biste postavili i rotirali tre¢u sliku na
zanimljiv nacin. Koristite slede¢e vrednosti: X=20, Y=25, za Rotate vrednost -2, da
biste dobili kontrast u odnosu na druge slike.

PROPERTIE!
5 4 1o )

oy

TRANSFORM
<+ 100.0% $ 100.0%0 Constrain

@ Rotate & EI

Oskew 27 00° §po°

3D Rotation

x 00° ¥ 00° =z 00°
3D Center point

x 0.0 Yy 0.0 z 0.0

B
1]
Rad li Help_
ad sa panhelima Duplicare Window <K
v . . . . Toalbars F
Sve $to radite u Flashu je povezano sa panelima. U ovoj lekciji, Timeline xT
koristi¢ete panel Library, panel Tools, panel Property, panel e i
Transform, panel History i vremensku liniju. U narednim lek- 3 ::;;““ :[3
cijama, koristi ¢ete panel Actions, panel Color, panel Motion Common Libraries »
o - q P .y . Motion Presets
i druge panele koji vam dozvoljavaju da kontrolisete razlicite
v - Actions TFa
aspekte vaseg projekta. Behaviors on
. . X .. i Compller Errors K
Posto su paneli sastavni deo radne povrsine u Flashu, veoma je Debug Panels »
. . .. Movie Explarer XFa
bitno za vas da znate da upravljate njima. Dutput [
a T o a R Al EE
Da biste otvorili bilo koji panel u Flashu, izaberite ime tog panela e i
iz menija Window. U nekim slu¢ajevima, mozda ce biti potrebno [;::um :'“
da izaberete panel iz podmenija na sledeci nacin Window > Transform ®T
Other Panels > History. Components i
Component Inspector  OF7 |
Podrazumevano je da se panel Property, panel Library i panel Tools L e
pojavljuju zajedno u desnom delu ekrana, dok se Timeline i Motion :TZ.L"?-THZT. o] sctne o
Editor pojavljuju na dnu, a pozornica na vrhu. Medutim, mozete BT | ;ﬁ}:,s':m R
pomerati panele na bilo koju poziciju koja vama odgovara. Z201End.Nla Bt b2l L

* Ako zelite da pomerite panel sa desne strane ekrana, prevucite
njegovu karticu na novu lokaciju.

¢ Ukoliko Zelite da fiksirate panel, pomerite njegovu karticu na Zeljeno mesto. MoZete ga postaviti na vrh, pri dnu
ili izmedu drugih panela. Plava boja vam pokazuje mesto gde mozete fiksirati vas panel.

¢ Da biste grupisali panele, prevucite karticu jednog panela preko kartice drugog.
* Da biste pomerili panel grupu, prevucite njen tamnosivi deo koji je pri vrhu.

Takode, imate mogu¢nost da prikazete vecinu panela u vidu ikona da biste ustedeli prostor i imali brz pristup
panelima. Pritisnite strelice u gornjem desnom uglu da biste prikazali panele kao ikone. Pritisnite strelice
ponovo da biste prosirili panele.
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Koris¢enje panela sa alatkama

Panel sa alatkama je uzan i izduZen panel koji se nalazi na krajnjoj desnoj strani
radne povrsine. Ovaj panel sadrzi alate za: odabir, crtanje i rad sa tekstom, boje-
nje i prepravljanje, navigaciju, i takode sadrzi opcije za alate. Cesto Cete koristiti
panele sa alatima da biste se lako prebacili sa alatke za selekciju na alatku za
tekst ili alatku za crtanje. Kada izaberete alatku, proverite deo sa opcijama koji
se nalazi pri dnu panela da biste dobili vise opcija i podesavanja neophodnih za
va$ zadatak.

Biranje i koris¢enje alatke

Kada izaberete alatku, opcije pri dnu panela sa alatkama i u panelu Property se
menjaju. Na primer, kada izaberete alatku za crtanje, tada se pojavljuju opcije
Object Drawing Mode i Snap To Object. Kada izaberete alatku za zumiranje,
pojavljuju se opcije za uvecanje i umanjenje.

Alatni panel sadrzi previse alata da bi mogao da ih prikaze odjednom. Neke
alatke su razmestene po grupama u panelu sa alatkama. Samo se pojavljuje alat
iz grupe koji je izabran poslednji. Jedan mali trougao u donjem desnom uglu
alata znaci da ima i drugih alata u grupi. Pritisnite i zadrzite pokazivacem ikonu
vidljive alatke kako biste videli alatke koje su vam dostupne i da biste izabrali
neku alatku iz menija.

Koristicete alatku za tekst da biste dali naziv vasoj animaciji.
1 Izaberite prvi sloj u vremenskoj liniji i pritisnite dugme Insert Layer.
2 Imenujte novi sloj text.
3 Zakljucajte ostale slojeve ispod njega kako ne biste slu¢ajno pomerili nesto
u njima.
4 U vremenskoj liniji pomerite kliza¢ na vremenskoj osi do kadra 36 i izaberite
kadar 36 u sloju text.

5 Izaberite Insert > Timeline > Keyframe (F6) da biste ubacili u sloju text novi
klju¢ni kadar u kadar 36.

v & photos a H
4l photo3 - 8 W DJ! i
o photo2 . am, s 0
4l photol a m, i
4l background a m. i
al o M mm®wE 38 2ok 295 [

Sastavicete tekst koji Ce se pojaviti u ovom sloju u kadru 36.
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6 U panelu sa alatkama, izaberite alatku za tekst koja je prikazana ¥ | {}

u obliku velikog slova T.

7 U panelu Property, izaberite iz padaju¢eg menija Static Text.

Opciju Static Text koristimo za bilo koji tekst koji zelimo samo
da prikazemo. Opcije Dynamic Text i Input Text koristimo
u interaktivne svrhe i one mogu biti kontrolisane od strane

e L
JTE:H:TI Taool {T)

T @

ActionScripta.
8 U panelu Property, izaberite tip i veli¢inu slova. Va§ kompjuter ‘!l
mozda necde imati iste fontove koji su prikazani u ovoj lekciji, ali v d

izaberite onaj koji je najsli¢niji po izgledu vasim fontovima.

9 Pritisnite pokazivacem obojeni kvadrat u panelu Property da biste izabrali boju tek-
sta. Mozete pritisnuti tocak za boju koji se nalazi u gornjem desnom uglu da biste pri-
stupili Adobeovom birac¢u boja. Takode, imate mogu¢nost menjanja Alpha procenta
u gornjem desnom uglu, koji odreduje nivo providnosti.

PROPERTIES

PROPERTIES

Text Tool Text Tool R
[ static Text I*] [ static Text |v] R
< CHARACTER < CHARACTER g‘
Family: |Rosewood Std [=] Family: |Rosewood Std [~] P
Style: [Regular =] Style: [Regular |=] "‘;}"
Size: 38 pt Letter spacing: 0 Size: 38pt Letter spacing: 0 E
color: [N ™ Auto kern Caolof [ Auto kern N
Anti-alias: [ Anti-alias for readability | v | I :000000 Textfilcolor|  Alpha:100
@@= T | N
< PARAGRAPH
rormar: [(E[E]E|E)
Spacing: 2= 0pt £ Zpx
Margins: +E 0 px E+ 0Opx
Behavior: | Single line lx]
Orientation: 25 | v M

10 Proverite dalije u sloju title izabran prazan klju¢ni kadar u kadru 24, a zatim pritisnite
pokazivacem deo pozornice gde Zelite da dodate tekst.
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11 Ukucajte naziv za opis slika koje se prikazuju na pozornici.

TIMELINE

al text &
¥ & photos
@l photo3
4l photo2
4l photol
] background

g

PERPRRDD .
OEEEEOO

=N ] { W] 3 120fs 295 [N |

12 Izadite iz alatke za tekst, biranjem alatke Selection Tool (& ).

13 Koristite panele Property ili Transform da premestite ili rotirate tekst na pozornici
po vasoj Zelji.

TRANSFORM

* 0.0 ¥y, 0.0 5 )

14 Za ovulekciju, vasa animacija je zavrsena! Uporedite vasu datoteku sa zavr$nom dato-
tekom 01End.fla.
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Prikaz alatnog panela

Panel sa alatkama sadrzi: alate za odabir, alate za crtanje i bojenje, alate za navigaciju. Deo sa
opcijama u panelu sa alatkama vam dozvoljava da modifikujete izabranu alatku. Prosireni meni
sa desne strane daje prikaz skrivenih alata. Crni kvadrat u prosirenom meniju sa desne strane
oznacava podrazumevanu (standardnu) alatku koja se pojavljuje u alatnom panelu. Velika slova u
zagradama predstavljaju precice na tastaturi za biranje tih alata. Obratite paznju da su alati slicne
funkcije grupisani zajedno.

m K1 Free Transform Tool (Q)
Selection (V) @ - "
[ GCradient Transform Tool (F)
Subselection (4) |y L] 0 3D Rotation Tool (W)
Alati za odabir
E & 3D Translation Toel (G)
; = & Pen Tool (P)
Lasso (L)
P {}*’ Add Anchor Point Tool (=)
Q} M 1}_ Delete Anchor Point Tool (-}
Text(T) | T I Convert Anchor Point Tool (C)
) . Line (1) | ™ =[] Rectangle Tool (R}
Alati za crtanje &
i tekst ] (23 Oval Tool (0)
Pencil (v) | ¥ [l Rmectangle Primitive Tool (R}
&, ‘= Oval Primitive Tool (0)
Deco (U) jf O PolyStar Tool
q?‘ » & Brush Tool (B)
Alati za & Spray Brush Tool (B)
uredivanje Eyedropper (1 //# - qua Bone Tool 0O
Eraser (E) | & "u} Bind Tool (Z)
Alati za Hand (H) Ef'} ] & Paint Bucket Tool (K)
navigaciju Zoom(M,2) | & #% Ink Bottle Tool (S)
4
Stroke color |[ ]
e
Fill color -
Deosa | Blackand white | my
opcijama Swap colors | &%
i
*{
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Vracanja koraka u Flashu

U savr$enom svetu sve ide po planu. Ali se ponekad morate vratiti korak ili dva una-
zad i poceti ponovo. Da biste vratili korake u Flashu, koristite komandu Undo ili panel
History.

Da biste se vratili korak unazad, izaberite Edit > Undo ili pritisnite CTRL/Command+Z.
Ako zelite da popravite korak koji ste ve¢ vratili, izaberite Edit > Redo.

Vracanje vise koraka u Flashu postizete na najlaksi nac¢in pomocu panela History, koji
prikazuje listu svih koraka koji su izvr$eni od trenutka otvaranja trenutnog dokumenta.
Zatvaranjem dokumenta brisete njegovu istoriju.

Da biste otvorili panel History, izaberite Window > Other Panels > History.

Na primer, ako niste zadovoljni sa novim tekstom koji ste dodali, mozete popraviti vas
rad i vratiti vas Flash dokument u prethodno stanje.

1 Izaberite Edit > Undo da biste ispravili poslednji napravljeni korak. Komandu Undo
mozete koristiti vise puta, tako da se mozete vratiti do 100 koraka unazad. U slu¢aju da
zelite da promenite maksimalan broj Undo komandi, izaberite Flash > Preferences.

2 Izaberite Window > Other Panels > History da biste otvorili panel History.

3 U panelu History, pomerite kliza¢ do koraka pre vase greske. Koraci koji su ispod su
zatamnjeni u panelu History i uklonjeni iz projekta. Da biste dodali korak, pomerite
kliza¢ nadole.

HISTORY HISTORY

43 Select Layers "

-

4 Select Layers

"'-j: Move Layers -L_n'“ Move Layers

4 Select Layers [i&ﬁ Select Layers

4+ Delete Layer I + Delete Layer

ELSelect Frames ELSElECI Frames

ELS-EIECt Frames ELSelect Frames

+7 Lock Layers + Lock Layers

+7 Lock Layers m +7 Lock Layers m
ELSelect Frames s ELSelect Frames &

=EE Delete lv | EDEETE 53
Replay (@] | [ Replay ]

Napomena: Ako uklonite korake u panelu History, a zatim napravite nove korake, uklonjeni
koraci vam vise nece biti dostupni.
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Pregled vaseg filma

Dok radite na projektu, bilo bi pozeljno da cesto pregledate vas film kako biste se uve-
rili da postizete Zeljeni efekat. Da biste videli na brz nadin kako ce film ili animacija
izgledati, izaberite Control > Test Movie. Takode, mozete pritisnuti CTRL+Enter ili
Command+Return da biste dobili pregled vaseg filma.

1 Izaberite Control > Test Movie. Flash vam prikazuje film u odvojenom prozoru.

01_workingcopy.swf

Flash automatski pusta film kao pregled. Ukoliko Zelite da prekinete film, izaberite
Control > Loop i uklonite znak potvrde.

2 Zatvorite prozor za pregled filma.
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Objavljivanje filma

Mozete objaviti film u Flashu ukoliko Zelite da taj film podelite sa drugima. Za vecéinu
projekata Flash kreira HTML i SWF datoteke. SWF datoteka predstavlja vas kona¢ni film
u Flashu, dok HTML datoteka daje instrukcije vasem veb pretrazivacu kako da prikaze
SWF datoteku. Potrebno je da smestite obe datoteke u istu fasciklu na vas veb server.
Kada smestite vas$ film, uvek ga testirajte da biste bili sigurni da funkcionise kako treba.

Napomena: Naucicete vise o opcijama za objavljivanje u lekciji 10.
1 Izaberite File > Publish Settings.
2 Pritisnite karticu Formats.

3 Izaberite Flash (.swf) i HTML (.html).

Publish Settings

Current profile:| Default B B+ T=le]q

{ | Flash | HTML

Type: File:

™ Flash (.swh) 01_workingcopy.swf i
M HTML (.html) 01_workingcopy.html ¥ ]
1 GIF Image (.gif) 01_workingcopy.gif 7]
1 IPEG Image (.jpg) 01_workingcopy.jpg ¥ ]
I PNG Image (.png) 01_workingcopy.png i
[ Windows Projector (.exe) 01_workingcopy.exe 7}
1 Macintosh Projector 01_workingcopy.app 7]

( Use Default Names )

( Publish ) ( Cancel ) (ESOKSSH
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4 Pritisnite karticu HTML.

Publish Settings
Current profile: | Default W [b1+afels]
[ Formats  Flash SSHTME

Template: | Flash Only B wie )

Playback: [ Paused at start B Display menu

Liloop [_| Davice fant
Qualiey: -
—
HIML alignment: | Default

Scale: | Default (Show all)
Horlzonual; Vertical:
Flash alignment: | Center W [ Center (1]

™ Show warning messages.

(o) (Coner) (D

5 Uklonite znak potvrde iz polja Loop.
6 Pritisnite opciju Publish.
7 Pritisnite opciju OK da biste zatvorili prozor.

8 Pronadite fasciklu Lesson01/ 01Start kako biste videli kreirane Flash datoteke.

B =Q
F o
01_workingcopy.fla 01_workingcopy.html 01_workingcopy.swf
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Kako naci resurse za koris¢enje Flasha

Posetite Adobeov veb site kako biste dobili kompletne i najnovije informacije o koris¢enju
panela, alata i drugih karakteristika u Flashu. Izaberite Help > Flash Help. Povezadete se
sa veb sajtom Adobe Community Help, gde mozete pronadi Flash dokumenta za pomo¢
i podrsku kao i druge veb sajtove koji su relevantni za korisnike Flasha. Takode, mozete
suziti rezultate pretrazivanja kako biste videli samo Adobeova dokumenta za pomo¢ i
podrsku.

Napomena: Ukoliko Flash otkrije da niste povezani sa internetom kada pokrenete aplikaciju,
tada pomocu opcija Help > Flash Help, otvarate Help HTML strane koje su instalirane zajedno sa
Flashom. Najnovije informacije moZete videti u datotekama Help ili u PDF formatu koji ste skinuli
sainterneta.

Ukoliko planirate da radite u Flashu kada niste povezani sa internetom, u tom slu¢aju
bilo bi pozeljno da skinete najnoviju PDF verziju Adobe Help sa sajta www.adobe.com/
go/documentation.

Informacije o savetima i tehnikama kao i o najnovijim proizvodima, mozete pronaci na
stranici Adobe Community Help na veb sajtu community.adobe.com/help/main.

Flash Help F1

Adobe Product Improvement Program...

Flash Exchange
Manage Extensions...

Flash Support Center
Adobe Online Forums
Adobe Training

Registration...
Deactivate...
Updates...
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Provera dopuna

S vremena na vreme, Adobe obezbeduje dopune za svoj softver. Mozete lako nabaviti
ove dopune pomocu programa Adobe Updater, pod uslovom da imate aktivnu internet
konekciju.

1 U Fashu, izaberite Help > Updates. Adobe Updater automatski proverava da li ima
dopuna koje su dostupne vasem Adobe softveru.

2 U prozoru Adobe Updater, izaberite dopune koje Zelite da instalirate i zatim pritisnite
opciju Download And Install Updates da biste ih instalirali.

" e—

Flash Help F1

Adobe Product Improvement Program...

Flash Exchange
Manage Extensions...

Flash Support Center
Adobe Online Forums
Adobe Training

Registration...
Deactivate...

Updates...

Napomena: Pritisnite opciju Preferences ako Zelite na svoj nacin da podesite opcije za kasnije
dopune. MoZete izabrati opciju koliko ce cesto Adobe Updater proveravati dopune, za koje aplika-
cije, kao i to da li da ih prebaci na vas kompjuter automatski. Pritisnite opciju OK da biste prihvatili
nova podesavanja.
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Pitanja za obnavljanje

1 Sta je pozornica?

2 U ¢emu je razlika izmedu kadra i klju¢nog kadra?

3 Staje to skriveni alat i kako mu mozemo pristupiti?

4 Navedite i opiSite dva nacina za vracanje koraka u Flashu?

5 Kako mozete naci odgovore na pitanja u Flashu?

Odgovori

1 Pozornica je mesto gde gledaoci prate film koji se prikazuje u Flash plejeru ili
veb pretrazivac¢u. Ona sadrzi tekst, slike i video zapis koji se pojavljuju na ekranu.
Objekti koji se nalaze izvan pozornice na pomoc¢noj radnoj povrsini ne pojavljuju
se u filmu.

2 Kadar je mera za vreme u vremenskoj liniji. Klju¢ni kadar je predstavljen u obliku
kruzi¢a na vremenskoj liniji i prikazuje promene u sadrzaju pozornice.

3 Nemoguce je prikazati sve alate u panelu Tools, jer ih ima previse. Iz tog razloga,
neki alati su grupisani i samo jedan alat iz grupe je vidljiv (a to je upravo ona alatka
koju ste najskorije koristili). Mali trouglovi na ikonama alatki predstavljaju skrivene
alate koji su dostupni. Da biste izabrali skrivenu alatku, pritisnite i drzite ikonu
alatke za alat koji je prikazan, a zatim iz menija izaberite skrivenu alatku.

4 Mozete vratiti korake u Flashu pomoc¢u komande Undo ili panela History. Da biste
vratili samo jedan korak, izaberite Edit > Undo. Da biste vratili odjednom vise
koraka, pomerite nagore kliza¢ u panelu History.

5 Izaberite Help > Flash Help da biste pronasli informacije o koris¢enju Flasha CS4 i
ActionScripta 3.0. Da biste dobili uvid u tutorijale, savete i druge resurse, izaberite
Help > Flash Support Center ili posetite adresu www.adobe.com.
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