
 

lekcija 1

 
Osnove Flasha

 

Åitajuñi ovu kçigu, nauåiñete kako da pomoñu Flasha MX pravite sloæene fil-

move sa animacijama, zvukom i interaktivnoãñu. Da bi se krenulo na dugo 

putovaçe, treba napraviti prvi korak. U ovom sluåaju, taj korak ñete napraviti 

kada nauåite kako da podesite parametre programa Flash i kako da çegov 

radni prostor prilagodite svojim potrebama.

U ovoj lekciji ñete najpre pregledati projekat koji ñete praviti tokom åitaça 

kçige. Nauåiñete kako da se snaœete u Flashovom radnom prostoru i gde da 

potraæite pomoñ kada vam zatreba. Saznañete i kako da napravite raspored 

panoa i kako da preåice sa tastature prilagodite svojim navikama. Na kraju, 

izmeniñete svojstva svog prvog filma i nauåiti kako da ga isprobate u Flash 

Playeru. 

 

Web lokacija 

ZooMX.

 

Chrissy Rey
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ÃTA ÑETE NAUÅITI

 

U ovoj lekciji ñete:

 

•

 

pregledati zavrãen projekat

 

•

 

saznati gde moæete nañi dodatnu pomoñ

 

•

 

podesiti parametre Flasha 

 

•

 

organizovati radni prostor pomoñu panoa 

 

•

 

definisati nov skup preåica sa tastature

 

•

 

izmeniti svojstva filma

 

•

 

snimiti film na disk i pregledati ga pomoñu komande Test Movie

 

POTREBNO VREME 

 

Za ovu lekciju potrebno je oko 30 minuta.

 

DATOTEKE LEKCIJE

 

Multimedijalne datoteke: 

 

Nema

 

Poåetne datoteke:

 

Nema

 

Zavrãen projekat:

 

Lesson01/Completed/zoo1.fla

 

NA SAMOM POÅETKU

 

Pre nego ãto prionete na pravàeçe filma u Flashu, napravite jedan direktorijum 

na åvrstom disku svog raåunara, u koji ñete snimati datoteke tokom rada kroz 

lekcije. Kada napravite direktorijum, otvorite Flash i bacite pogled unaokolo. 

Zatim ñemo pogledati projekat koji ñete napraviti pomoñu lekcija iz ove kçige.

 

1)  

 

Napravite direktorijum na åvrstom disku i dajte mu ime FlashTFS.

 

Da biste mogli da radite u Flashu, podrazumeva se da poznajete rad na raåunaru. 

Ako vam, pak, treba pomoñ da biste napravili direktorijum, pronañi ñete je u 

dokumentaciji koju ste dobili uz raåunar.

Nakon ãto napravite direktorijum, spremni ste za otvaraçe Flasha – a to je 

vaæan prvi korak!

 

2)  

 

Otvorite Flash.

 

Kad otvorite Flash, ugledañete ekran nalik na onaj koji je prikazan na sledeñoj 

stranici. Postoje sitnije razlike u verzijama Flasha za Windows i za Macintosh. 

U obe verzije videñete pano Welcome, koji vas pita kako biste æeleli da koristite 

Flash. Ako ste veñ podesili Flash prema uputstvima sa panoa Welcome – ne bri-

nite! Samo izaberite Window > Panel Sets > Default Layout da bi izgled Flasha 

na vaãem ekranu pratio kçigu.
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Flash ima glavni meni, koji se na Windows raåunaru obiåno nalazi na vrhu 

Flashovog glavnog prozora, dok je kod Macintosha na vrhu ekrana. Ovaj meni i na 

Windows i na Macintosh raåunaru ima opcije File, Edit, View, Insert, Modify, Text, 

Control, Window i Help. Na Macu OS X, osim nabrojanih, postoji i opcija Flash.

Kada pokrenete Flash, panoi Color Mixer, Color Swatches, Components i 

Answers standardno se nalaze s desne strane ekrana, a kutija sa alatkama (engl. 

 

toolbox

 

) s leve strane. Vremenska osa (engl. 

 

timeline

 

) smeãtena je na vrhu ekrana 

(o çoj ñete viãe saznati u lekciji 4). Pano Properties nalazi se na dnu (Windows), 

odnosno blizu dna (Macintosh) ekrana; srediãçi deo ekrana zauzima podruåje za 

rad, poznato pod imenom pozornica (engl. 

 

stage

 

). 

Prazan dokument na pozornici je nov film. Svaki put kada otvorite Flash, pro-

gram automatski pravi nov film koristeñi standardne parametre, koje ñete neãto 

kasnije u ovoj lekciji nauåiti da izmenite. Podrazumevano ime novog Flash filma 

nalazi se pri vrhu ekrana i trebalo bi da bude Untitled-1 ili sl. Kada film snimite 

na disk pod drugim imenom, kao ãto ñete kasnije u ovoj lekciji i uåiniti, ime na 

ekranu ñe se takoœe promeniti.

 

Dokumente u Flashu uglavnom nazivamo filmovima jer je Flash 
prvobitno nastao kao program za animacije. Naravno, Flash u danaãçe vreme moæe 
pruæiti mnogo viãe od animacije, ali je termin film veñ pustio koreçe.

ime filma

panoipozornicapano�

properties

vremenska osameni

kutija sa�

alatkama

traka za obaveãtenja

n a p o m e n a
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3)  

 

Izaberite File › Close.

 

Vremenska osa i pozornica nestaju, kao i deo opcija u meniju – ostaju samo File, 

Edit, Window i Help (i Flash na Macu OS X). Ekran sada treba da izgleda kao na 

sledeñoj slici: 

 

4)  

 

Izaberite File › New.

 

Vremenska osa i pozornica ponovo se pojavàuju. I meni ñe se proãiriti da bi prika-

zao sve opcije koje ste videli kada ste prvi put otvorili Flash. Sem toga, trebalo bi 

da se ime filma promenilo. Ako se vaã prvobitni film zvao Untitled-1, ime novog 

filma biñe Untitled-2. Kada ga zatvorite, a zatim ponovo otvorite, Flash automat-

ski aæurira ime svakog novog filma, a numerisaçe poåiçe iz poåetka.

 

5)  

 

Otvorite zavrãenu Web prezentaciju ZooMX u åitaåu Weba. 
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Da biste videli Web lokaciju ZooMX, treba da budete prikàuåeni na 
Internet. Ako niste prikàuåeni na Internet, moæete je pogledati sa CD-a koji ste dobili uz 
ovu kçigu – otvorite help.html i pritisnite hipervezu (engl. 

 

link

 

). Pri tom, morate biti 
svesni da verzija Web lokacije koju moæete pogledati bez prikàuåivaça na Internet neñe 
funkcionisati dobro kao verzija koju biste dobili na Internetu jer su pojedinim datotekama 
potrebni podaci koji su dostupni samo na Internetu.

 

Zavrãenu Web lokaciju ZooMX, koja je napravàena u Flashu MX, nañi ñete na 

adresi www.flashtfs.com. Kada miãem pritisnete hipervezu za ZooMX, prezenta-

cija se otvara u novom prozoru åitaåa Weba veliåine 600 

 

×

 

 400 piksela. Web loka-

cija ZooMX moñi ñe da bude prikazana samo u najnovijoj verziji Flash Playera. 

Da biste videli dokumente Flasha na Webu, morate instalirati Flash Player na 

raåunaru, a uz çega ñete dobiti i najnoviju verziju Flash Playera. Flash Player se 

takoœe isporuåuje uz posledça izdaça åitaåa Weba, kao i uz mnoge operativne 

sisteme.

Ako ste pak preuzeli i instalirali plejer, verovatno ste primetili da je uåitan 

veoma brzo. Macromedia se trudi da datoteka Flash Playera uvek bude mala.

Posvetite nekoliko trenutaka razgledaçu Web lokacije ZooMX. Na çoj se 

nalaze slike, animacija, zvuk, video prikazi, dinamiåki sadræaj, a sve to uz mnogo 

interaktivnosti. Kada savladate sve lekcije, znañete kako da dodate svaki od ovih 

elemenata.

Dok pravite sadræaj Web strana u programu Flash MX, radiñete sa .fla dato-

tekama. Njih ureœujete i koristite samo u Flashu – to nisu datoteke koje moæete 

videti na Webu. Datoteke tipa .swf koje viœate na Webu jesu verzije .fla datoteka 

i sadræe samo one informacije koje su potrebne za gledaçe datoteke pomoñu Flash 

Playera. Na kraju ove lekcije saznañete kako da pogledate Flash film u formatu 

.swf. Kada savladate lekcije iz ove kçige, umeñete da objavite svoje zavrãene 

Flash filmove kao .swf datoteke, zajedno sa HTML-om potrebnim za çihovo 

prikazivaçe u åitaåu Weba.

 

GDE NAÑI POMOÑ

 

Åak i kada savladate sve lekcije iz kçige, moæe vam zatrebti dodatna pomoñ u 

radu sa Flashom. Neki resursi su obezbeœeni uz Flash, a mnoãtvo drugih dostu-

pno je na Internetu.

Ako vam je joã aktivan prozor åitaåa Weba, otvoren u prethodnoj veæbi, vratite 

se na Flash.

n a p o m e n a
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1)  

 

Prouåite pano Welcome. 

 

Pano Welcome se pojavi kada prvi put otvorite Flash. Daje vam uputstva kako 

da podesite okruæeçe u skladu s tim ãta u çemu nameravate da radite. Dizajneri 

ñe pre koristiti pozornicu, kutiju sa alatkama i panoe koji se odnose na crtaçe, 

dok ñe programeri verovatno radije upotrebiti pano Actions.

Pano Welcome moæete da otvorite i iz menija Help (Help > Welcome). Istra-

æujte pano pritiskajuñi miãem svaku opciju, a zatim pratite uputstva za organi-

zovaçe panoa na ekranu. Izaberite Window > Panel Sets > Default Layout da 

biste se vratili na podrazumevanu organizaciju panoa.

 

2)  

 

Izaberite Help › Lessons. 
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Pano Lessons sadræi veñi broj lekcija koje ñe vam pomoñi na samom poåetku. 

Koristiñe vam da se vratite na ove lekcije kad god vam iskrsne problem u vezi s 

nekom od tema navedenih u prozoru.

 

3)  

 

Izaberite Help › Using Flash da biste u åitaåu Weba otvorili Flash datoteke za 
pomoñ. 

 

Na Windows raåunaru, datoteke za pomoñ moæete otvoriti i pritiskom tastera 
F1. To je verovatno jedna od najvaænijih preåica sa tastature i treba je zapamtiti!

 

Flash datoteke za pomoñ sadræe informacije ponuœene u Flashovom priru-

åniku u formatu koji moæete pretraæivati koriãñeçem hiperveza. Datoteke se 

pojavàuju u åitaåu Weba razvrstane po temama. Abecednu listu svih tema za koje 

je ponuœena pomoñ moæete otvoriti pritiskom na dugme Index ili moæete iskori-

stiti pogodnost pretrage pritiskom na dugme Search.

 

4)  

 

Vratite se u Flash i izaberite Help › Flash Support Center. 

 

Ako ste prikàuåeni na Internet, biraçe ove opcije odveãñe vas u Macromedijin 

Flash Support Center. Flashov centar za podrãku najboàe je mesto za dobijaçe 

informacija o Flashu, ukàuåujuñi i uputstva za rad, tehniåku podrãku, informacije 

o obuci i joã mnogo toga. 

s a v e t �
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5)  

 

Vratite se u Flash i prouåite pano Answers. 

 

Pano Answers se nalazi na dnu grupe panoa s desne strane ekrana. Ako ga ne 

vidite, izaberite Window > Answers. Ovaj pano je veoma koristan jer Macromedia 

preko çega pruæa najnovije resurse i pomoñ u samom Flash okruæeçu. Sadræaji 

ovog panoa mogu biti aæurirani ako ste prikàuåeni na Internet.
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6)  

 

Posetite neke od resursa koji su navedeni u dodatku C ako vam treba dodatna 
pomoñ.

 

Mnogi resursi, kao ãto su FlashLite (www.flashlite.net) i Flash TFS (www.flash-

tfs.com), imaju oglasne table, izvorne datoteke i uputstva za rad ãto unekoliko 

olakãava savladavaçe Flasha. Ne morate sve odmah da ih posetite, ali, dok 

budete åitali ovu kçigu ili dok budete radili u Flashu, moæe vam zatrebati 

dodatna pomoñ koju ovi resursi nude.

 

7)  

 

Upiãite se u Flashovu listu za slaçe poruka.

 

Zajednica Flashovih korisnika odliåno je mesto za informisaçe o Flashu. Upi-

sivaçem u listu za slaçe poruka, u moguñnosti ste da razmeçujete informacije 

sa drugim ålanovima zajednice korisnika Flasha. Nekoliko lista za slaçe poruka 

opisano je u dodatku C – pronaœite onu koja bi vama odgovarala i prijavite se.

 

PODEÃAVANJE PARAMETARA

 

Flash nudi ãirok spektar parametara, koji omoguñuju da kontroliãete sve: od toga 

koliko koraka ñete moñi da se vratite komandom Undo, do toga na koji naåin ñete 

birati objekte. U ovoj lekciji, podesiñete veñinu parametara vaãeg primerka Flasha 

tako da odgovaraju Flashovim podrazumevanim parametrima i saznañete za ãta 

sluæe mnogi od çih.

 

1)  

 

Izaberite Edit › Preferences (Flash › Preferences na Macu OS X) i pojaviñe se 
prozor Preferences. Miãem pritisnite jeziåak kartice General, podesite Undo 
Levels na 

 

50

 

, a preostale opcije podesite kao ãto je prikazano na sledeñoj slici. 
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Opcija Undo Levels kontroliãe broj koraka koje Flash pamti. Ako treba da 

napravite ispravke u svom radu, Flash ñe moñi da se vrati onoliko koraka unazad 

koliko ste zadali u poàu Undo Levels. Podeãavaçe ove opcije na 50 dovoàno je 

da ispravite skoro sve greãke. Ali, morate imati na umu da se svaki korak åuva u 

memoriji. Ako opciju Undo Levels podesite tako da pamti veñi broj koraka, vaã 

raåunar bi, nakon ãto izvrãite izvestan broj operacija, mogao poåeti da usporava. 

Ukoliko primetite da raåunar poåiçe da radi sporije i da se javàaju problemi, vra-

tite se na prozor Preferences i u poàe Undo Levels upiãite maçi broj.

Na kartici General u prozoru Preferences potvrœene su opcije Shift Select i 

Show Tooltips. Prva vam omoguñuje da izabranim objektima dodate nove tako 

ãto ñete ih pritisnuti miãem dok istovremeno dræite taster Shift. Ako miãem priti-

snete dodatni objekat, a da pri tom ne dræite pritisnut taster Shift, biñe izabran 

samo taj objekat. Kada ne potvrdite Shift Select, izabrani objekti se dodaju 

samim pritiskom miãa na çih – bez dræaça tastera Shift. (Ukoliko vas ovo zbu-

çuje, ne brinite; kasnije u kçizi ñemo se ovim ponovo baviti. Trenutno je bitno 

samo da opcije u prozoru Preferences budu pravilno postavàene). Show Tooltips 

je brz sistem za pruæaçe pomoñi, zgodan za poåetnike. Ako potvrdite ovu opciju, 

Flash ñe prikazati kratak opis ili oznaku dugmeta ili nekog drugog kontrolnog 

objekta svaki put kada nad çima zaustavite pokazivaå miãa.

Nepotvrœene opcije na kartici General prozora Preferences jesu Disable Post-

Script (samo za Windows), Disable Panel Docking (samo za Windows), Disable 

Timeline Docking, Span Based Selection i Named Anchor on Scene. Ukoliko 

imate probleme pri ãtampaçu na PostScript ãtampaåu sa Windows raåunara, 

moæete izabrati opciju Disable PostScript, mada ñe to usporiti ãtampaçe. Kada na 

Windows raåunaru potvrdite opciju Disable Panel Docking, panoi ñe ostati raz-

dvojeni i neñe priaçati jedan uz drugi. Viãe o panoima i priaçaçu saznañete 

kasnije u ovoj lekciji. Biraçem opcije Disable Timeline Docking, Flash ñe vre-

mensku osu prikazati kao prozor koji slobodno pluta na ekranu, nepovezan sa 

glavnim Flashovim prozorom. Opcijom Span Based Selection odreœujete da li 

ñete vremenskom osom upravàati koristeñi vremenske intervale ili kadrove filma 

– viãe o tome saznañete u lekciji 4. Moæete odabrati opciju Named Anchor on 

Scene da bi Flash dodao „imenovano sidro” prvoj slici svake scene, ãto ñe vam 

omoguñiti da koristite dugmad Forward i Back u åitaåu Weba za kretaçe od 

scene do scene.

 

Moæe vam se dogoditi da dobijete upozoreçe Missing Font nakon otvaraça 
Flashove datoteke napravàene na drugom raåunaru. Ovo upozoreçe pokazuje da font 
koriãñen u datoteci koju ste otvorili nije instaliran na vaãem raåunaru. Moæete odabrati 
standardnu zamenu (engl. 

 

default substitute

 

) ili navesti font kojim æelite da zamenite 
font koji nedostaje.

s a v e t �
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2)  

 

Pritisnite jeziåak kartice Editing i izaberite opciju Show Pen Preview. Pobri-
nite se da ostale opcije u odeàcima Pen Tool i Vertical Text ne budu potvrœene 
i da sve opcije u odeàku Drawing Settings budu podeãene na Normal. 

 

S obzirom na to da joã niste poåeli da radite sa alatkama za crtaçe, neki para-

metri na kartici Editing mogu vam biti nepoznati. Kada upoznate rad sa alatkama 

za crtaçe, vratite se u prozor Preferences i podesite ove parametre.

Opcije u kategoriji Pen Tool podeãavaju naåin rada alatke Pen (pero), jedne od 

alatki za crtaçe koju ñete nañi u kutiji sa alatkama. Izaberite opciju Show Pen 

Preview i Flash ñe prikazivati segment linije pre nego ãto dovrãite çegovo crtaçe 

alatkom Pen. Opcija Show Solid Points, koja nije standardno potvrœena, odreœuje 

na koji ñe naåin taåke na linijama biti prikazane pri koriãñeçu alatke Pen ili 

alatke Subselection (alatke za podizbor). Kada ovu opciju potvrdite, izabrane 

taåke ñe biti ãupàe, dok ñe taåke koje niste izabrali biti popuçene. Ako ovu 

opciju ostavite nepotvrœenu, biñe obrnuto. Potvrdite opciju Show Precise Cursors 

i Flash ñe alatku Pen prikazati u obliku konåanice (krstiña), umesto u standard-

nom obliku pera.

Nijedna opcija iz odeàka Vertical Text nije standardno potvrœena, ãto u potpu-

nosti odgovara projektu koji ñemo praviti u lekcijama. Ali, one vam mogu zatre-

bati ubuduñe, te je dobro upoznati se sa çihovim funkcijama. Ako izaberete 

opciju Default Text Orientation, svaki tekst koji dodate filmu biñe postavàen 

vertikalno. To je naroåito korisno ako radite sa fontovima azijskih jezika. Opcija 

Right to Left Text Flow, kada je potvrœena, uåiniñe da tekst teåe zdesna nalevo, 

umesto standardnog sleva nadesno. I ova opcija vam moæe zatrebati ako koristite 

fontove nekih azijskih jezika. Konaåno, opcija No Kerning iskàuåiñe podeãavaçe 

razmaka izmeœu slova za svaki vertikalno postavàen tekst u filmu. To je korisno 

za poboàãaçe meœuslovnog razmaka u nekim fontovima.
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U odeàku Drawing Settings podeãavate parametre za crtaçe i odreœujete u 

kojoj meri æelite da Flash prepoznaje oblike i time vam pomaæe pri crtaçu. Vred-

nosti ovih parametara su relativne – zavise od rezolucije ekrana i trenutnog ste-

pena uveñaça. Dakle, stepen prepoznavaça oblika ñe varirati dok uveñavate i 

umaçujete sliku pri crtaçu. Parametar Connect lines odreœuje koliko blizu linija 

koju crtate sme da priœe veñ nacrtanoj liniji, a da se pri tom krajça taåka prve linije 

ne spoji sa çoj najbliæom taåkom druge linije. Ponuœene opcije su Must be close, 

Normal i Can be distant. Parametar Smooth curves moæe biti podeãen na Off, 

Rough, Normal ili Smooth i odreœuje u kojoj meri ñe Flash izgladiti krivu koju 

crtate alatkom Pencil. Parametar Recognize lines odreœuje koliko linija treba da 

bude prava da bi je Flash prepoznao kao takvu. Kada Flash prepozna ovaj seg-

ment, pretvoriñe ga u savrãeno pravu liniju. Sliånu funkciju ima opcija Recognize 

shapes, s tim ãto se ona koristi za odreœivaçe u kojoj meri nacrtani oblik treba da 

izgleda kao krug, elipsa, pravougaonik, kvadrat, prav ugao ili ugao od 180 stepeni 

da bi ga Flash prepoznao kao odgovarajuñi geometrijski oblik i ponovo iscrtao. Oba 

ova parametra, i Recognize lines i Recognize shapes, mogu biti podeãena na Off, 

Strict, Normal ili Tolerant. Parametar Click accuracy odreœuje koliko treba pribli-

æiti kursor nekom obliku da bi Flash taj oblik prepoznao. Kao ãto ñete videti kada 

poånete da radite sa alatkama za crtaçe u sledeñoj lekciji, dok pomerate miãa, kur-

sor se meça, u zavisnosti od nacrtanog oblika i trenutno izabrane alatke za crtaçe. 

Opcija Click accuracy, koja moæe biti podeãena na Strict, Normal ili Tolerant, 

zadaje na kolikoj ñe udaàenosti od crteæa kursor promeniti izgled.

 

3)  

 

Pritisnite jeziåak kartice Warnings i izaberite sve opcije. 

 

Na samom ste poåetku, te je verovatno najboàe da podesite Flash tako da vas 

upozori kad god se dogodi neãto ãto bi moglo da prouzrokuje zbrku. Sve opcije na 

kartici Warnings standardno su potvrœene, ali vam neñe trebati tolika upozoreça 
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kada provedete neko vreme radeñi u Flashu. Na primer, ako potvrdite opciju 

Warn on missing fonts, Flash ñe vas upozoriti svaki put kada otvorite Flashov film 

sa fontom koji nije instaliran na vaãem raåunaru. Ako åesto radite sa datotekama u 

kojima su koriãñeni fontovi koji nisu instalirani na vaãem raåunaru, i æelite da 

iskàuåite ovaj parametar, otvorite prozor Preferences i poniãtite izbor ove opcije.

 

4)  

 

Pritisnite OK da biste zatvorili prozor Preferences.

 

Kada pritisnete OK, biñe primeçene sve izmene koje ste napravili u prozoru Pre-

ferences. Poãto ste se pozabavili podeãavaçem parametara, vreme je da se joã 

malo posvetimo istraæivaçu okruæeça programa Flash.

 

RAD SA PANOIMA 

 

Flash MX organizuje mnoãtvo svojih alatki i komandi na panoima, sliåno upotrebi 

paleta u drugim programima. Panoi sadræe alatke koje omoguñuju da vidite, orga-

nizujete i meçate elemente u filmu. Dok radite, moæete prikazati pano, sakriti ga 

i promeniti çegovu veliåinu. Moæete åak kombinovati ili spojiti panoe kako biste 

olakãali rad u Flashu. Za razliku od okvira za dijalog i prozora, panoi mogu da 

ostanu na ekranu dok radite, ãto ñe vam olakãavati postavàaçe elemenata u film.

U sledeñoj veæbi, rasporediñete panoe i potom snimiti na disk utvrœeni raspo-

red panoa za buduñu upotrebu.

 

1)  

 

Zatvorite panoe Color Swatches i Answers.

 

Pano zatvarate kada miãem pritisnete „dugme” skrivenog menija, koje se nalazi u 

gorçem desnom uglu naslovne trake panoa i izaberete Close Panel. Ako je pano 

sveden na traku, a dugme skrivenog menija se ne pojavi, miãem pritisnite naslo-

vnu traku kako biste proãirili pano i otkrili dugme. 

 

Pano moæete zatvoriti i ako naslovnu traku pritisnete desnim tasterom miãa 
(Windows), odnosno ako je pritisnete dræeñi taster Control (Macintosh) i iz menija izabe-
rete stavku Close Panel.

 

Zasad neñemo koristiti ove panoe, te ih je boàe zatvoriti. Ako vam kasnije 

zatrebaju, pronañi ñete ih u meniju Window. Odaberite Window > Answers da 

biste otvorili pano Answers, ili Window > Color Swatches kako biste otvorili pano 

Color Swatches.

 

2)  

 

Izaberite Window › Align da biste otvorili pano Align. 

 

Pano Align moæete otvoriti i pritiskom tastera Ctrl+K (Windows), odnosno 
Command+K (Macintosh). 

s a v e t �

s a v e t �
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Na panou Align iz menija Window nalazi se velik broj opcija i veñina je name-

çena drugim panoima. Mnoge panoe iz ovog menija koristiñete u narednim 

lekcijama.

 

3)  

 

Miãem pritisnite levu stranu naslovne trake panoa Align i prevucite ovaj pano 
preko panoa Components koji se nalazi na desnoj strani ekrana. Spustite pano 
Align na pano Components.

 

Leva strana naslovne trake svakog panoa sadræi kontrolni element koji omogu-

ñuje da prevlaåite pano. Ako na Windows raåunaru pokazivaåem miãa preœete 

preko naslovne trake, kursor ñe se izmeniti, pokazujuñi da moæete prevuñi pano. 

Dok pomerate pano Align, Flash prikazuje konturu panoa (pogledajte sliku ispod 

teksta) koja odreœuje çegovu poziciju i veliåinu. Primetiñete da se pri prevla-

åeçu panoa Align preko panoa Components, pojavàuje kontura oko grupe panoa 

na desnoj strani ekrana, pokazujuñi da ñe, ukoliko ga tu spustite, pano biti sme-

ãten u tu grupu. Prilikom prevlaåeça panoa, pojaviñe se kontura koja ga predsta-

vàa. Takoœe, kada ovaj pano prevuåete preko panoa Components, pojaviñe se 

kontura koja uokviruje sve panoe u toj grupi. 

dugme skrivenog menija panoa
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Kada spustite pano, trebalo bi da se usidri uz panoe Color Mixer i Compo-

nents. Pano Align bi trebalo da se naœe na dnu ove grupe panoa – ako se on tu 

sam ne smesti, prevlaåite panoe gore-dole dok Color Mixer ne bude na vrhu, 

pano Components u sredini, a pano Align na dnu. 

 

4)  

 

Saæmite pano Components tako ãto ñete pritisnuti miãem çegov naslov 
ili strelicu levo od naslova.

 

Dobro je ãto panoi u Flashu MX mogu da se saæimaju. Moæete saæeti pano koji tre-

nutno ne koristite da biste dobili viãe prostora na ekranu za panoe koje koristite. 

Saæeti pano ñete otvoriti kada pritisnete miãem naslov panoa (ili strelicu). Kada 

saæmete pano, nestaje dugme skrivenog menija na desnoj strani naslovne trake.

 

5)  

 

Izaberite Window › Save Panel Layout. Kada se otvori prozor Save Panel Lay-
out, u poàe Name upiãite 

 

Flash TFS

 

, i pritisnite OK. 
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Kada izaberete Window > Save Panel Layout, pojaviñe se okvir za dijalog Save 

Panel Layout. Sada treba da upiãete ime za vaãu grupu panoa. Ako pokuãate da 

grupu panoa snimite na disk pod imenom koje je veñ u upotrebi, Flash ñe vam to 

staviti do znaça. Biñe vam ponuœena opcija da snimite novu grupu panoa preko 

postojeñe, ali pre nego ãto upiãete novo ime, razmislite dobro da li je to ono ãto 

æelite da uradite.

Pritisnete OK i Flash ñe snimiti raspored panoa. Nije bilo mnogo straãno, zar 

ne? Ovaj raspored panoa moæete otvoriti u svako doba biraçem Window > Panel 

Sets > Flash TFS. Ukoliko æelite da koristite standrdni raspored panoa, izaberite 

Window > Panel Sets > Default Layout. Naravno, odreœene panoe ñete koristiti 

viãe nego neke druge. Da biste lakãe pristupali grupama panoa koje åesto kori-

stite, napravite nove grupe panoa.

 

Ako hoñete da obriãete grupu panoa, samo izbriãite datoteku sa imenom grupe 
koju æelite da uklonite iz direktorijuma Panel Sets, smeãtenog unutar direktorijuma Flash 
MX Configuration. Poloæaj direktorijuma Flash MX Configuration zavisi od operativnog 
sistema. U Windowsu 98 i ME, direktorijum je C:\[Windows Directory]\Application 
Data\Macromedia\Flash MX. Za Windows NT direktorijum je C:\[Windows Direc-
tory]\profiles\<korisniåko ime>\Application Data\Macromedia\Flash MX. U Windowsu 
2000 i XP, direktorijum je C:\Documents and Settings\<korisniåko ime>\Application 
Data\Macromedia\Flash MX. U novijim verzijama operativnog sistema za Macintosh, u 
jednokorisniåkom okruæeçu direktorijum je HD: System Folder:Application Support:Mac-
romedia:Flash MX, dok je u viãekorisniåkom okruæeçu smeãten u HD:Users:<korisniåko 
ime>:Documents:Macromedia:Flash MX. Na Macu OS X, to je HD/Users/<korisniåko 
ime>/Library/Application Support/Macromedia/Flash MX.

 

UPOTREBA PREÅICA SA TASTATURE

 

Moæda ste primetili da mnoãtvo komandi u Flashu MX moæete izvrãiti pomoñu 

preåica sa tastature umesto izborom stavki iz menija. Standardne preåice sa tasta-

ture se lako koriste, ali ãta ako æelite da ih podesite tako da odgovaraju vaãim 

navikama? Ili, ãta ako æelite da koristite preåice sa tastature koje znate od ranije iz 

nekog drugog programa? U sledeñem veæbaçu saznañete kako da ih podesite.

 

1)  

 

Izaberite Edit › Keyboard Shortcuts (Flash › Keyboard Shortcuts na Macu OS X) 
da biste otvorili prozor Keyboard Shortcuts. 

 

Prozor Keyboard Shortcuts ima veliki broj opcija. Na vrhu prozora nalazi se opcija 

Current Set, koja prikazuje koji komplet preåica sa tastature trenutno koristite. 

Flash MX nudi veliki izbor razliåitih kompleta preåica sa tastature, ukàuåujuñi 

i one za Macromedijine programe Fireworks i FreeHand, ali je Flash MX podra-

zumevana opcija.

s a v e t �
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2)  

 

Proverite da li je Current Set podeãen na Flash MX i pritisnite dugme za kopi-
raçe (prvo sleva). Kada se otvori prozor Duplicate, podesite Duplicate Name na 
Flash TFS i pritisnite OK. 

 

Kada pritisnete OK, prozor Duplicate se zatvori i Current Set je podeãen na 

Flash TFS.

Praktiåno je imati standardni komplet preåica sa tastature na koji se moæete 

vratiti ako neãto zabràate. Zato, kopirajte standardni komplet Flash MX i izme-

nite kopiju, a ne original. Doduãe, Flash je otporan na gluposti – neñe vam 

dozvoliti da napravite ijednu promenu na kompletu preåica Flash MX.

Poãto ste nauåili kako da podesite preåice sa tastature, ako ste dovoàno hrabri, 

pokuãajte da promenite komplet Flash MX da biste videli ãta ñe se dogoditi. Tre-

balo bi da dobijete upozoreçe da ga ne moæete meçati.

preimenovanjekopiranje

brisanje
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Ne samo da moæete kopirati postojeñe komplete preåica sa tastature, veñ 

moæete i da im promenite ime i da ih izbriãete. Izaberite komplet kome hoñete 

da promenite ime ili koji æelite da izbriãete iz Current Seta i pritisnite dugme 

Rename, odnosno Delete. Jedino komplet Flash MX ne moæete obrisati, niti mu 

moæete promeniti ime.

 

3)  

 

Podesite parametar Commands na Drawing Tools, i sa liste izaberite Dropper. 

 

Parametar Commands ima åetiri opcije: Drawing Menu, Drawing Tools, Test 

Movie Menu i Actions Panel. Izaberite neku od çih da saznate åime raspolaæe. 

Na spisku komandi Drawing Tools navedene su i preåice sa tastature za svaku 

alatku za crtaçe koja se nalazi u kutiji sa alatkama. Primetiñete da je podrazume-

vana preåica sa tastature za alatku Eyedropper (pipetu s bojom), koja je isto ãto i 

Dropper, slovo I. Ako vam je do avanture, samo napred: birajte redom preostale 

opcije iz liste Commands i proçuãkajte po spisku komandi svake od çih.

Kada sa spiska komandi izaberete alatku Eyedropper, preåica za tu alatku 

pojavàuje se u poàu Shortcuts pri dnu prozora Keyboard Shortcuts. Moæete 

dodati drugu preåicu, ili izbrisati ili izmeniti postojeñu. Poåeñemo dodavaçem 

preåice koja se veñ koristi.
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4)  

 

Pritisnite dugme Add Shortcut (+) da biste dodali novu preåicu. Kada se u 
poàu Shortcuts pojavi ‹empty›, pritisnite taster E na tastaturi. 

 

Kada se pojavi <empty> u poàu Shortcuts, to znaåi da ste dodali preåicu sa 

tastature, ali da joj joã niste dodelili taster. Trebalo bi da Flash ovaj red automatski 

izabere, a isti tekst (<empty>) trebalo bi da se pojavi u poàu Press Key. Ako se ne 

pojavi, izaberite red <empty> u poàu Shortcuts i miãem pritisnite poàe Press Key.

Preåicu sa tastature E veñ koristi alatka Eraser (gumica). Stoga, kada u poàe 

Press Key upiãete E, pojaviñe se poruka da je ova preåica veñ u upotrebi. Ako 

biste sada pritisli dugme Change, otvorio bi se prozor Reassign sa pitaçem da li 

æelite da ovu preåicu dodelite alatki Eyedropper. Ako to neñete da uradite, priti-

snite dugme Cancel u prozoru Reassign da biste zatvorili prozor.

 

Kada je poàe Press Key aktivno, Flash ñe zabeleæiti jedno slovo i tastere 
Control (Windows), Command (Macintosh), Alt (Windows), Option (Macintosh) i Shift, 
ako ih u tom trenutku pritisnete. Ukoliko æelite da dodate veliko E preåicama sa tastature, 
ne treba da pritiskate Shift+E, nego samo E.

 

5)  

 

Izaberite sadræaj poàa Press Key i pritisnite D na tastaturi. Miãem pritisnite 
dugme Change.

 

Taster D nije preåica ni za jednu komandu tako da se neñe pojaviti poruka o 

greãci kada ga pritisnete. Kada pritisnete Change, Flash ñe dodati D kao preåicu 

sa tastature za alatku Eyedropper.

n a p o m e n a
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Ako pritisnete dugme Help u prozoru Keyboard Shortcuts, Flashove 
datoteke za pomoñ otvaraju se na delu koji govori o radu sa preåicama.

 

6)  Pritisnite OK.
Kada pritisnete OK, Flash ñe saåuvati novi Flash TFS raspored preåica sa tasta-

ture, i prozor Keyboard Shortcuts ñe se zatvoriti. Postavite pokazivaå miãa preko 

alatke Eyedropper u kutiji sa alatkama (izgleda kao pipeta). Ukoliko za trenutak 

zadræite pokazivaå miãa nad alatkom, pojaviñe se kratak opis alatke (engl. Tooltip) 

i u çemu nova preåica sa tastature. Ako se preåica ne pojavi, izaberite Edit > 

Keyboard Shortcuts i proverite da li je Flash TFS odabran kao Current Set. Uko-

liko nije, odaberite ga i pritisnite OK. 

PODEÃAVANJE SVOJSTAVA DOKUMENTA

Pre nego ãto poånete da pravite film u Flashu, trebalo bi da razmislite o çegovim 

osobinama, kao ãto su veliåina i boja pozadine. Dobro bi bilo da odredite dimenzije 

filma, jer po zavrãetku umetniåkog dela posla moæe biti teãko napraviti izmene.

Dimenzije filma – kao i boju pozadine, uåestalost smeçivaça slika i podeoke 

leçira na pozornici – podesite pomoñu panoa svojstava (Properties) i okvira za 

dijalog Document Properties. U sledeñoj veæbi podesiñete boju pozadine i dimen-

zije filma.

n a p o m e n a
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1)  Proverite da li ste otvorili nov film. Pritisnite poàe Background na panou 
svojstava. Kada se otvori paleta boja, otkucajte #FFC055 (narandæasta) na odgo-
varajuñem mestu i pritisnite Enter, odnosno Return. 

U prvom veæbaçu u ovoj kçizi zapoåeli ste nov film. Ako ste ga zatvorili, ili 

ste se igrali alatkama za crtaçe i dodali neãto na pozornicu, napravite nov film 

(File > New).

Buduñi da ñete åesto koristiti pano Properties, vreme je da se s çim malo boàe 

upoznamo. Properties je veliki pano na dnu ekrana pomoñu koga moæete podeãa-

vati razne stvari. Reaguje zavisno od konteksta, ãto znaåi da prikazuje parametre 

samo za ono ãto je u datom trenutku izabrano. Ako niãta niste izabrali, niti ste 

miãem pritisli neãto u kutiji sa alatkama ili na vremenskoj osi, pano svojstava ñe 

prikazivati parametre dokumenta. Na levoj strani panoa svojstava treba da se 

nalazi ikonica Flasha. Desno od çe treba da stoji reå Document koja sugeriãe da 

su u datom trenutku prikazana svojstva dokumenta. Ime Flash filma, koje je sada 

podeãeno na Untitled-2 ili sl., takoœe ñe se nañi desno od ikonice. Ako pano svoj-

stava na vaãem ekranu ne odgovara u potpunosti gorçoj slici, izaberite alatku 

Arrow iz kutije sa alatkama (crnu strelicu, a ne belu), a zatim pritisnite pozornicu.

Za pozadinu filma moæete upotrebiti samo åiste boje, pa se na paleti samo 

takve i nalaze. Paleta se sastoji od 216 standardnih boja koje se mogu koristiti na 

Webu, ali boja za pozadinu projekta na kome ñemo mi raditi nije na çoj. Dakle, 

morañete da upiãete heksadecimalnu vrednost u odgovarajuñe poàe. Kada otvo-

rite paletu, pokazivaå miãa postaje pipeta – alatka kojom moæete izabrati bilo koju 

boju unutar Flasha. Da biste odabrali boju za pozadinu filma, dovoàno je da 

pokazivaå miãa postavite na çu i pritisnete taster miãa. Ukoliko pipetom priti-

snete van Flashovog prozora, izabrana boja pozadine biñe #FFFFFF (bela).

dugme za�

veliåinu�

boja�

pozadine�

uåestalost�

slika�

dugme�

za pomoñ�

dugme za podeãavanje�

pristupaånosti�

dugme za proãirivanje/saæimanje�

dugme za�

objavljivanje�
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Kao ãto ñete videti u sledeñem koraku, boju pozadine moæete podesiti i u pro-
zoru Document Properties, ali tu ne moæete uneti heksadecimalnu vrednost boje.

2)  Pritisnite dugme Size na panou svojstava da biste otvorili prozor Document 
Properties.
Kada pritisnete dugme Size na panou Properties, otvoriñe se prozor Document 

Properties. U ovom prozoru moæete podesiti uåestalost smeçivaça slika, dimen-

zije (ãirinu i visinu), boju pozadine i podeoke na leçiru za film. Sem toga, pomoñu 

dugmadi Match (Printer i Contents) moæete podesiti dimenzije filma tako da odgo-

varaju aktuelnoj veliåini dokumenta ili trenutnom sadræaju filma (a to je bilo ãta ãto 

ste nacrtali na pozornici). Ako hoñete da boju pozadine i dimenzije vratite na pod-

razumevane Flashove vrednosti, pritisnite dugme Default. 

Prozor Document Properties moæete otvoriti i pritiskom na tastere Ctrl+M 
(Windows), odnosno Command+M (Macintosh), ili ako izaberete Modify > Document.

3)  Podesite Width na 600 i ostavite Height na 400.
Podeoci leçira su standardno izraæeni u pikselima (px), tako da moæete upisati 

600 u poàe za ãirinu, a Flash ñe mernu jedinicu px dodati kada primenite parame-

tre. Ako nameravate da koristite neku drugu mernu jedinicu za film, odaberite 

jednu od ponuœenih u padajuñem meniju Ruler Units pri dnu prozora Document 

Properties. Za datoteku koju zajedno pravimo obavezno koristite piksele, jer 

moæe doñi do zabune u kasnijim operacijama ukoliko se merna jedinica na leçiru 

vaãe pozornice razlikuje od ove koju koristimo u uputstvima.

Podrazumevana veliåina filma je 550 × 400 piksela. Najmaçi film koji je 

moguñe napraviti bio bi 1 × 1 piksel, a najveñi – 2880 × 2880. Podesite veliåinu 

filma na 600 × 400 jer je te dimenzije koristio dizajner pri izradi originalnog nacrta 

filma koji ñemo zajedno praviti.

s a v e t �

s a v e t �
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Ovaj film bi po zavrãetku mogao biti prikazan i u prozoru åitaåa 
Weba koji je podeãen na 640 × 480. Dakle, podeãavaçem dimenzija filma na 600 × 400 
napraviñete film koji ñe se uklopiti u prozor svakog åitaåa Weba.

4)  Pritisnite dugme Make Default, a zatim dugme OK.
Joã jedan koristan element prozora Document Properties jeste dugme Make 

Default. Ako åesto koristite iste parametre za svoje nove filmove, moæete ih 

uåiniti standardnim, pritiskom na dugme Make Default. U narednim lekcijama 

napraviñete nekoliko filmova koristeñi iste dimenzije i istu boju pozadine, te 

biste mogli sebi olakãati posao standardizujuñi ova svojstva.

Kada pritisnete OK, prozor Document Properties ñe se zatvoriti i film ñe se 

prilagoditi dimenzijama koje ste zadali.

5)  Izaberite File › Save. Kada se otvori okvir za dijalog Save As, potraæite direk-
torijum FlashTFS na åvrstom disku, upiãite zoo1.fla u poàe File Name (Windows), 
odnosno Save As (Macintosh), i pritisnite Save. 

Upravo ste saåuvali svoju prvu Flash datoteku u direktorijumu FlashTFS. 

Åestitamo! Ponovo ñete koristiti ovu datoteku, te je zasad ostavite otvorenu.

n a p o m e n a
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TESTIRANJE FILMA

Flash moæe da prikaæe film u sopstvenom okruæeçu, ali ova projekcija ne poka-

zuje uvek taåno kako ñe Flashov film izgledati kada bude objavàen na Webu. Kao 

ãto ste nauåili na poåetku ove lekcije, u Flashu radite s datotekama tipa .fla, dok 

su datoteke koje ñete na kraju izraœivati za Web i koje ñe biti prikazivane u Flash 

Playeru – .swf datoteke. Komanda Test Movie Flashovog plejera omoguñuje da 

pregledate filmove kao .swf datoteke.

1)  Proverite da li vam je datoteka zoo1.fla joã uvek otvorena. Izaberite Control 
› Test Movie. 

Kada izaberete Control > Test Movie, Flash pravi jednu .swf datoteku u istom 

direktorijumu u kom ste saåuvali svoju .fla datoteku, otvara je u zasebnom pro-

zoru i prikazuje je u Flash Playeru. Flashov prozor za pregledaçe filma zvañemo 

prozor Test Movie. U lekciji 12 saznañete joã mnogo toga o prozoru Test Movie.

U ovoj fazi, .swf verzija datoteke zoo1.fla priliåno je nezanimàiva. To je jedna 

prazna narandæasta povrãina. Ne brinite – dodañete vi ovoj datoteci joã mnogo toga u 

narednih 11 lekcija i ta prazna narandæasta povrãina uskoro ñe obilovati sadræajima.

2)  Zatvorite prozor Test Movie.
Niste uneli nikakve promene u film zoo1.fla dok ste ga testirali, te nema potrebe 

da datoteku ponovo snimate. Zasad je samo dræite otvorenu, jer ñete joj veñ u 

sledeñoj lekciji neãto dodati. 
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ÃTA STE NAUÅILI

U ovoj lekciji ste:

• posetili zavrãenu Web lokaciju ZooMX (strane 7-10)

• saznali gde da potraæite dodatnu pomoñ (strane 10-14)

• nauåili kako da podesite Flashove parametre (strane 14-18)

• preuredili panoe i formirali namensku grupu panoa (strane 18-21)

• definisali nov komplet preåica sa tastature (strane 21-25)

• podesili boju pozadine i dimenzije Flashovog filma (strane 25-28)

• pogledali Flashov film u Flash Playeru (strana 29)


